Cannot install Chrome extension

khadkhad Social Choreographer

Team Member
This discussion was created from comments split from: Persistent red "!" badge in Chrome extension.

Comments

  • I had a similar problem. When I went to update the 1Password extension to Chrome it consistently fails to install.

    When I use the AgileBits site, via the 1Password program's Preferences screen, I get the failure screen. The Chrome error dialog box reads:

    Package is invalid. Details: 'Invalid value for 'page_action.default_icon'.'.

    When I try to add the extension via the Chrome Store page. The error dialog reads:

    There was a problem adding the item to Chrome. Please refresh the page and try again.

    Well, I did try again, and again, ... both ways even after a shutdown and cold restart. Then I did something really dicey, I removed the old version of the extension, rebooted and tried to re-install. Now I have no extension for 1Password in Chrome, not even the one with a red exclamation mark. Any suggestions?

  • khadkhad Social Choreographer

    Team Member

    What happens if you create a new Chrome profile and try installing only the 1Password extension and no other extensions?

  • Same behavior. I could not find 1Password in the Chrome store, if I did not first logon to chrome. However, when I logon to Chrome it drags in other extensions. So I again cleared the Chrome UserData/Default directory and used the 1Password preference screen to add the extension. It failed to load. I did look at the Extensions for this new instance of Chrome and the McAfee Enterprise Extension was loaded. I am not sure there is a way to prevent McAfee without uninstalling it (which creates all kinds of problems on my system -- past experience).

  • efbaconefbacon
    edited July 2013

    This morning I recovered the UserData/Default and Extensions directories for Chrome from my system backups. This puts me back to my original and operational state. I have not noticed the red exclamation mark, but only tried one site with Chrome and 1Password. Thank you for your support or should I say choreography.

  • khadkhad Social Choreographer

    Team Member

    Please do keep me posted if you have any further trouble. We'd be happy to investigate further as necessary.

  • Posting here, so as not to start a new thread on a similar topic.

    I just tried installing the Chrome Extension and nothing happened. I hit the "manual link" and got the note under the URL bar that said something about the Chrome Store and dismissed it. The download looked like it finished, but I couldn't find it anywhere. And, when I tried to quit chrome it said the download was in progress. I gave up.

    The other browsers (firefox & safari) were a breeze.

    I don't use Chrome much/at-all, so not worried, but I figured you'd want to know.

    David

  • khadkhad Social Choreographer

    Team Member

    Thanks for following up on this, @djbressler. Could you tell me the URL of the "manual link" you used? It sounds like you might be using the URL of an old page rather than clicking the button in 1Password's preferences.

  • It's installed.

    It's a bunch of things... one being that the download location folder opened behind chrome. So I didn't see it until I quite Chrome. I did manage to drag-and-drop it, and finally it installed. There were a few buttons I had to click, and simply had to try it until it worked (about 4 times), but it did.

    Sorry for the confusion - I think it's more about Chrome than 1Password.

  • khadkhad Social Choreographer

    Team Member

    It sounds like you used the old method to download the CRX file and drag/drop it. It should install directly from the Chrome Web Store. What was the URL of the "manual link" you used? Did you come upon it by clicking the button in 1Password's preferences to install the extension or some other way? I just want to make sure there isn't something we need to fix. :)

    Thanks!

  • I just had a similar problem to this, and resolved it by setting my default downloads folder in Chrome to the main Downloads folder in my home directory (Mac OS X 10.8.5, Chrome 30). It had previously been set to a folder on my second drive. Hope that helps...

This discussion has been closed.