My incredible journey, open if you dare.

Hi there,

I need help as I've tried everything with the exception of restoring my Mac to get rid of this issue. I've had 1P4 installed but it was not syncing properly to iCloud. The 1P4 on my iPhone said it was syncing and backing up correctly (checked settings, iCloud account, etc, all that)

So I ended up deleting 1P4 on my Mac using the method an admin posted here on the the discussion boards. (Deleting the app, deleting the ~/Library/Containers agilebits files and emptying trash)

I then proceeded to redownload the app from the App Store like I did previously, and try to sync again. It still was not syncing my iCloud data over (it was but only about 10-20 entries were downloaded, not any of the rest.) So, I tried everything again. And again, and again. I did this about several times until I decided to try to delete the iCloud 1Password data file itself from iCloud. So, before I did anything, I made a clean back up (using iTunes file sharing which, had a snag as well since it would constantly be "syncing with the gears", [and yes I'm using the latest update]) Anyway, I was able to backup a clean file and tucked it away for safe keeping. That said, I proceeded to turn off "iCloud sync" in 1Password for iPhone, (and any other syncing options), then, I went to Settings > iCloud > Storage and Backup > Manage Storage > delete "onepassword" data from iCloud.
With that out of the way, I rebooted all my iOS devices, waited 10 minutes (as per instructions on another thread), then I proceeded to delete my 1Password4 app (and any relating files I could find in Finder with "agilebits"). After emptying trash, I re-downloaded it again from the AppStore.

I opened up 1Password4 on the Mac, and IMPORTED my fresh clean backup file I tucked away and loaded all my entries that way. I then proceeded to go to Preferences > Sync > Change Syncing > Disable Syncing. This turned off the syncing to the file, I then turned ON syncing for iCloud. This then UPLOADED the clean data file into my iCloud account. With that done, I waited another 10 minutes just for good measure, and proceeded to install 1Password for my iPhone again. After installing, it detected my iCloud account and prompted for my master password. I entered it, and let it work for a couple minutes while the entries populated. With now a clean file on iCloud my iPhone and Mac are now properly in sync.....

HOWEVER :

My only one gripe now is that, something must have happened during the several times I reinstalled 1P4 for Mac because whenever I open it now, it ALWAYS shows the splash screen as if I just installed it. Not to mention it does not save any of the preferences from before (with the exception of keeping the 1Password Mini Icon running or not). So, now, 1Password sometimes doesn't even ask for my Master Password anymore because the preferences (unless I manually click the gear in 1Password Mini to "Lock" it down) then it will always just pop up without prompting for my Master Password because somewhere, somehow, the preferences are not being saved (or something along those lines)

Anyway, sorry for the long post but I wanted to give as thorough of an explanation of my troubles as possible in case anyone is able to help me.

As of now, I'm still using it, but have to deal with no Master Password and continually pressing "Awesome! Let's Get Started", as well as whenever closing the 1P4 window having to be asked "Enable 1Password mini?" every time on exit, (the Do Not Show This Message Again tick box does nothing)

Thank you for your time in reading this. Any ideas/suggestions as to what I can do?

Comments

  • roustemroustem AgileBits Founder

    Team Member

    Thank you for your post!

    We have seen similar issue during out testing but we only last night we found the solution. It was posted in Apple Developer forums:

    Turns out, OS X does not like when you manually delete the folder in ~/Library/Containers. If you do that, none of the application preferences will be saved. In 1Password 4 case, this includes welcome screen as well as the sync settings.

    To fix this problem, log out-log back in, or restart your Mac after deleting ~/Library/Containers folder.

  • Thank you! I will delete ~/Library/Containers/ agilebits folders and then restart my Mac, be back in a few minutes to post the results.

  • Huzzah! It worked. I deleted the agilebits folders in ~/Library/Containers, trashed em, and restarted my Mac. After restarting I opened 1P4 and (yes it gave me the splash screen again but that was just because I'm starting fresh), after it detected my iCloud settings, I logged in with my Master Password, it synced everything, then I closed it. I didn't open it again, but for good measure just rebooted my Mac at that point. After opening it up just now, it did NOT show me the splash screen. So everything seems to be working and in proper order. I just finished installing the safari extension and that works too.

    Thank you again! Much appreciated.

  • Uno_LavozUno_Lavoz
    edited October 2013

    I just finished reading your whole post to see if I could help. Glad you got it solved.

    Another first-world problem ticked off the list. :D

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @agileuser2,

    That's super great to hear, I'm glad Roustem was able to help you. Just one more thing, on Mavericks, if you try to delete the plist files in ~/Library/Preferences, the same thing occurs, you have to log out and log back in before you do anything else or the plist files comes back messing everything up.

This discussion has been closed.