Failing on Firefox [Resolved with Firefox 27]

jefferisjefferis Junior Member
edited February 2014 in 1Password 3 – 6 for Mac

All I get is a blank screen or junk in 1Password on Firefox 20 -24 I've reinstalled the extension with no improvement. It works in Chrome and Safari. Is this fixed in version 4? I need to pay for an upgrade to make it work? Or will I still have the same problems??


  • Hi @jefferis,

    Unfortunately, we have been having some problems with the latest versions of Firefox. We're working with Mozilla to get this sorted as soon as possible. There is a post about your options here:

    But the short version is that yes, version 4 will fix the problem. We do hope that soon it will be fixed properly soon though :)

  • HendelHendel Junior Member

    I'd love to upgrade - 1Password is a fantastic app, which I've relied on across multiple platforms for years. One of the very first things I install on a new system/device. Unfortunately, you and Apple have decided that my otherwise perfectly functional Mac Pro (with upgraded video card) can't run Lion/Mavericks (or 1Password 4). Replying here because the thread Megan points to above is closed. What options do I and other left behind users have for resolving this issue?

  • Hi @Hendel,

    I'm sorry to hear that Firefox is still giving you trouble. Unfortunately, since this bug is largely on Mozilla's end, there is only so much that we can do here. I'd recommend looking at the options provided in that original post: perhaps looking into another browser for the time being might be the best solution.

    I do apologize if you feel left behind with this upgrade to 1Password 4. We certainly didn't intend to make 1Password 3 users feel this way. I know it does seem as if technology is moving awfully fast these days, but there are simply some tools available to developers for Lion and Mavericks that weren't available in earlier OS versions. These tools have allowed us to do some really great things in 1Password. That being said, we fully intend to continue support for 1Password 3, and will do everything in our power to ensure that it continues to work for you.

  • HendelHendel Junior Member

    (Sigh). Thanks for the response, anyway @Megan. I do use both Firefox and Safari regularly, but prefer Firefox w/my collection of extensions. Is this an open item with Mozilla, or did they change something foundational that 1Password relied on, which is expected to be broken from this point forward? Just have to keep watching/hoping for a Mavericks update to MLPostFactor...

  • Hi @Hendel,

    What version of Firefox are you currently using? I've chatted a bit with one of our coding gurus, and you might see better behaviour if you try out the beta version of our extension. You can find the 1Password 3 extensions here, simply click the checkbox to 'Allow beta extensions'.

    Please let me know if that helps at all!

  • HendelHendel Junior Member

    Thought I'd already enabled 1Password betas (I'm on the Firefox beta channel, currently 26.0). Re-installing the Firefox plugin with the beta switch worked! At least for now, I'm back in business - thanks!

  • Hi Hendel,

    Just to avoid confusion: using a beta version of the browser won't update your non-native extensions to the beta version. However, I'm so glad to hear that things are finally working for you! Let's hope that the extension continues to behave itself.

    Thanks so much for your patience!

  • 1Password 3.8.21 (build 32009)
    Firefox 25.0
    OS X 10.8.5

    I would think others would be having this problem too, but I can't find anything on it...

    Sometimes when I hit "Command-\" in Firefox to get the 1Password "Logins" window, the popup window appears but the login list is empty -- just blank white. The icons on the left edge are there (the ones for Logins, Credit Cards, Identities, etc) and their appearence changes as I click on them, but the main area of the windows remains blank. Dismissing the 1Password window and recalling it with Command-\ does not help.

    I saw another posting describing a Firefox problem, but it's extremely rare for me to have more than one Firefox window open, and I've never gotten a Javascript or any other error message, so it doesn't seem to be the same thing.

    The only way I've found to rectify the problem is to restart the Firefox application. Then 1Password works normally, at least for awhile.

    The problem seem to occur randomly. It occurs every two or three days, but sometimes several times in a day. I think it mostly occurs after the browser extension has locked; I unlock it as usual and after my pw is accepted, the empty Logins window appears. This morning the problem occurred the first time I used Command-\ after the computer was in sleep mode all night.

    It's been happening for a couple of months or so, but I'm sorry I haven't kept good records; I did upgrade from OS X 10.6.8 to 10.8.4 and then 10.8.5 beginning on September 1, so it could be related to my move to Mountain Lion. I am pretty much always up to date on Firefox, so I've been through a few releases of that since the problem started.

    I have a screenshot and am happy to provide a diagnostic report if that will help any. I'm running an older iMac (Early 2008 24" iMac with ATI Radeon HD 2600 Pro graphics) currently on OS X 10.8.5.

    I love 1Password--it's been a lifesaver--but this is annoying me! Any ideas?

    Brian Holmes

  • Hi @Brian_Holmes,

    I've merged your discussion with an existing discussion on the topic, I hope you don't mind :)

    I am sorry to hear that you're having difficulties with the Firefox extension. Could you try installing the beta version of the Firefox extension? Please see my post (#6) above for directions on how to install the beta extension. This should get you all sorted out ... but please let me know if you are still having difficulties!

  • edited November 2013

    Hi Megan -- Thanks for the reply. Sorry to be so long getting back to this (I thought I'd get an email if there were any response, but apparently not).

    I've successfully installed the beta version of the Firefox extension. Since my problem seems to occur randomly, it will be hard to decide if it's fixed or not, but I will let you know here sooner (if it doesn't work) or later (once I've decided it's fixed. Just for completeness: I'm now on Firefox 25.01 and just had the blank window problem yesterday (before I put the 1P beta extension on).

    P.S. (Just saw "Notification Preferences" and changed to get email notifications)

  • Hi @Brian_Holmes,

    Thanks for letting us know that you at least might be fixed up. :) I do hope the solution is permanent, but please let us know if you do notice it again!

  • Hi- I am having exact same troubles with FF 25.0.1 and 1Password 3.8.21. I can't upgrade to 1Password 4 because I am currently on OSX 10.7.5. It's been going on for months and happens every day, requiring a restart of FF. I just kept hoping it would go away on its own with just basic troubleshooting techniques like updating software, uninstalling the extension and re-installing it, etc. I have now turned on beta and am running FF extension 3.9.20.b4. Since it happens to me everyday, I hope I will know something soon and will post back. Please don't leave those of us unable to go to iPassword 4 in the dust! Thanks!

  • Hi @linvie,

    Please let me know if the beta extension fixes this for you - I've got my fingers crossed! We certainly don't mean to leave our 1Password 3 users in the dust, our developers are working to solve this issue properly for you. :)

  • Firefox 25.0.1 1password 3.8.21

    I log into my bank's ID Window and click submit after 1P does it's thing. The window asking for the password then opens but there is no 1Password Icon, so I can not get 1P to finish the login.

    It used to work.

  • Sadly, I must report that the beta Firefox extension 3.9.20.b4 does not solve the problem for me. I just experienced the "blank white logins window" again. Luckily it occurs only every few days, but it's driving me crazy that I can't figure out what triggers it!

  • eva_seva_s 1Password Alumni

    Hi macalp,

    I need a little more detail to help you troubleshoot your issue.
    When was the last time the extension worked for you?
    Have you tried uninstalling and reinstalling the browser extension?
    Rebooted the computer?
    Can you post a screenshot of the second window you are referring to?

    Thanks in advance.

  • Hi @Brian_Holmes,

    I'm so sorry to hear that this issue is still driving you crazy. The annoying thing on our end is that because it is so intermittent, it becomes very hard to track down. If you could remember if a particular action triggers it (opening a new tab or waking the computer from sleep for example) our developers would really appreciate any light you could shed here. In any case, they are still looking for a way to squash this.

    Our new extension design in 1Password 4 has fixed this issue. If you are able to upgrade, our extra-upgrade discount is still in effect. ;)

  • Hi @macalp,

    I've merged your comment with an existing discussion in the 1Password 3 forums. It sounds like you might be having the same trouble as has been reported here. (Please let me know if I'm misunderstanding!)

    Please take a look at Khad's post Trouble in Firefox: Wrong Logins, Blank Extension, etc. as well.

  • Same for me @Brian_Holmes. The problem has become much more intermittent rather than every day. Megan, I will start reporting in specifics when it happens to help with the troubleshooting. I wish I could upgrade but can't.

  • Hi @linvie,

    I do apologize for the trouble here - I know it sucks. But from the sounds of it the beta extension at least reduces the occurrence. If you do notice a specific instance where it is always happening, please let us know - we'd love to squash this bug!

  • Hi Megan et al- I think I've figured out a specific instance that contributes to the 1P issues. I'm a developer and so one of the sites I visit every day is a staging environment. The site is password protected in the htaccess file so I have to type my username and pword to the security window that pops. (I've never really figured out how to use 1P to populate the window - so I just type it in.) The last couple of days I have opened the staging environment in Chrome and have used FF to do the rest of my day to day stuff. Although I wouldn't say I'm trouble free, it seems a whole lot better.

  • Hi @linvie,

    Thanks so much for sharing your experience here, I'll be sure to pass it along to our developers. There's a topic in the 1Password 3 Extension forum that suggests that the latest Firefox betas (beginning with 27) seem to show significant improvement here. If you're feeling adventurous, please give it a try and see if things behave a bit more nicely there!

  • Thanks linvie and Megan for the additional info on this issue. Unfortunately I can't think of anything in my usage that corresponds to linvie's staging environment. (I believe I'm able to use 1P to populate everything I access with Firefox.) I will, however, keep a close eye on my Firefox version (I just upgraded to 26.0) and when I get to 27 I'll let you know if it has resolved the issue for me.

  • Hi @Brian_Holmes,

    I've got my fingers crossed that 27 works for you! Please let us know :)

  • Good news: now that I've been on Firefox 27 (and 27.0.1) for awhile now, I'm pretty confident that the new Firefox has fixed the problem I was having with Firefox/1Password (getting a blank white logins window). I know this is an old thread, but just wanted to let you know.

  • Hi @Brian_Holmes‌,

    Thanks so much for updating us here. I'm so glad that this has been properly resolved! I think we can safely close this thread - if you run into any other snags, feel free to start up a new discussion :)

This discussion has been closed.