1Click icons in bookmarks bar not working in Mavericks?

I upgraded my two iMacs from Mountain Lion to Mavericks (10.9, Safari 7.0) recently. 1Password (3.8.21) seems to be working except the 1Click icons in the bookmarks bar bring up the correct web page but do NOT enter the userid or password.

Clicking the 1Password icon in the menu bar and then selecting the same site, Wells Fargo bank for example, brings up the page and then DOES enter the userid and password.

I deleted the old bookmarks bar icon and created a new one by dragging from the 1Password app's Logins list Same thing - brings up the page but does NOT enter the login information.

I created a link on the desktop by dragging from the 1Password app's Logins window. Double clicking it brings up the web page and DOES enter the userid and password.

Does a Safari/1Password configuration option somewhere need to be changed to get 1Click bookmarks bar icons to enter the login information?


  • Hi @SVanDee,

    I'm sorry to hear about the trouble you're having with 1Click Bookmarks in Safari. I've done some testing on my end, and I'm seeing the same thing as you, so I've passed this issue along to our tech gurus to see if they can make a bit more sense of things.

    I can, however, confirm that 1Click Bookmarks are behaving as expected in 1Password 4. If you are interested in upgrading, please send me an email at [email protected] agilebits .com and I'll do what I can to help. (Please include a link to this discussion in your message so we can easily connect the dots!)

  • golfsierragolfsierra Junior Member

    @Megan: I DISAGREE with your statement! I am using 1pw version 4.0.3 and all the items I drag from 1pw to the bookmark bar in Safari 7.0 just open the page but do NOT fill out the data in Mavericks anymore ...

  • I'm on 4.0.5 @golfsierra and there it works fine. You may post your issue in the 1P4 section to see how it can be resolved.

  • Hi @golfsierra,

    I do apologize for the confusion here. I'm not quite sure why it seems to work on my computer with Mavericks with Safari 7.0, I've done a bit further reading on our Known Issues discussion, and found that the developers are aware of an issue with 1Click Bookmarks in Safari and are looking for a solution.

    (Mavericks) 1Click Bookmarks won't work in Safari 7. For now, hold the command key while clicking on the bookmark, it should then work.

    In the meantime, could you let me know if holding the command key helps your bookmarks play a little more nicely! :)

  • golfsierragolfsierra Junior Member
    edited November 2013

    Hi Megan,

    for me Cmd-click is set to open a link in a new tab as standard. When I disable this feature and click Cmd-link the page is opening and the AUTOFILL is working (but only AFTER I dragged the item from 1password do the bookmark bar AGAIN ... the original link in the bookmark bar was NOT working ... hopefully it is working WITHOUT Cmd soon ... (presently I am on 4.0.9)

  • Hi @golfsierra,

    I'm glad to hear that you have found a way to make those 1Click Bookmarks behave for you. I do apologize that it has been a bit of a process, but I can assure that our developers are working on a better solution. I just can't give you any more details than that :)

  • golfsierragolfsierra Junior Member

    @Megan: Any updates on WHEN this bug will be finally fixed? In v3 it worked so well and the present situation with v4 is annoying :(

  • Hi @golfsierra,

    We've done some testing here, and 1Click Bookmarks seem to be behaving properly. If you're still unable to get them working, I'd love to take a bit of a closer look at your system. Could you please send us a Diagnostics Report?

    Download the 1Password Troubleshooting utility and follow the instructions to generate the report.

    Then attach the entire file to an email to us: [email protected] agilebits .com

    Please do not post your Diagnostics Report in the forums, but please do include a link to this thread in your email, along with your forum handle so that we can "connect the dots" when we see your Diagnostics Report in our inbox.

    Once we see the report we should be able to better assist you. Thanks in advance!

  • golfsierragolfsierra Junior Member

    Diagnostic report sent ...

  • Hi @golfsierra,

    Thanks so much for sending that along - we'll follow up directly via email so that things don't get muddled up between there and here :)

  • golfsierragolfsierra Junior Member

    Well ... today I installed the new version 4.1.3 and it solved my problems PARTLY. My webmail site of the company is working perfect as it did with version 3 of 1password BUT my banking site still does NOT autofill ... (but it works using the "command-click"-trick) :(
    any new suggestions?

  • Hi @golfsierra,

    I'm sorry to hear that you're still having difficulties with 1Click Bookmarks. Is 1Password locked or unlocked when you are activating these bookmarks? We are currently tracking a bug where 1Click Bookmarks are not filling information when 1Password is locked. If the app is unlocked, 1Click Bookmarks should behave correctly. Can you confirm this on your end?

  • golfsierragolfsierra Junior Member

    Hi @Megan,

    I am really sorry to say that the problem exists even the keychain is ALREADY UNLOCKED :(
    if I click the bookmark nothing happens as soon as I click CMD-click it fills out correctly

  • Hi @golfsierra,

    I've conferred with a colleague, and I'd like you to try something for me. Please disable 'Animate form filling' in Preferences > Browsers and see if your bookmark behaves better then.

    Let me know if it does! But in either case, I'd love to get the web address of this problem Login so we can do some further testing on our end.

    Thanks for helping us to track this down :)

  • golfsierragolfsierra Junior Member

    Hi @Megan, well ... unchecking the "Animate form filling" does NOT make any difference ... same (faulty) behavior ... the problem URL is: https://banking.raiffeisen.at

  • Hi @golfsierra,

    I'm so sorry to hear that this didn't help. I've filed this website in our issue tracker. Our form filling gurus will take a look at this and see if we can't improve 1Password's behaviour with this site.

  • sjksjk oversoul

    Team Member

    Hi, @golfsierra.

    I get inconsistent results with 1Click bookmark filling of the Bankleitzahl, Konto oder Depot, and Verfügernummer die letzten 8 Stellen fields on the page where https://banking.raiffeisen.at redirects. The issue still appears to be what Chris mentioned to you in email last month about the filling process aborting before the webpage finishes loading, which we do hope to improve so it's more reliable.

    During my testing even your Command-Click workaround would sometimes fails. I'd prefer to avoid the side effect of opening an empty tabs by simply loading the page and if it doesn't fill then use the keyboard shortcut to do it.

  • golfsierragolfsierra Junior Member
    edited January 2014

    hi @sjk,
    thanks for your info ... yes, that's the way I actually use 1password presently ... simply loading it and using the shortcut-fill if that doesn't work ... I hope you will find a fix soon ... this feature worked so fine under version 3 ... really sad that it doesn't so in version 4 :(

  • sjksjk oversoul

    Team Member

    Hi, golfsierra.

    1Password 4 is brand new from the ground up and we haven't finished restoring 1Password 3 features and functionality. @MikeT wrote more about that: here.

This discussion has been closed.