Browser Extension: how do I change the assigned keychain / keyfile

I'm using the firefox extension. Unfortunately I do not know how to change the keychain which the extension adresses.
E.g. I work in the "normal" windows program with several keyfiles: work and private. In this program I can change via the menu.
When I am using the browser extension the extension always tries to open the first keychain. How can I change this?

Comments

  • svondutchsvondutch

    Team Member
    edited November 2013

    You'll need to un-install (and then re-install) the Firefox extension. Other browsers handle the removal of the SQLite file automatically, but you will need to do this manually for Firefox:

    1. Open Firefox.
    2. Remove the 1Password extension.
    3. Enter about:support in the address bar and press Return.
    4. Click the "Show Folder" button.
    5. Quit Firefox.
    6. In the Explorer window that opened, go up one level in the file hierarchy.
    7. Move the OnePassword.sqlite to your desktop.

    ​Then reinstall the Firefox extension from 1Password for Windows' preferences on the Browsers tab.

    Once everything is working well, you can safely move the OnePassword.sqlite file on the desktop to the trash.

  • DBrownDBrown 1Password Alumni

    Just for clarity's sake, I believe the SQLite file @svondutch refers to above is Firefox's local copy of your 1Password data.

  • Thank you very much. It worked. To extend my question: how to master it in chrome?

  • svondutchsvondutch

    Team Member
    edited November 2013

    how to master it in chrome?

    In Chrome, the procedure is easier:

    1. Open Chrome
    2. Click the "customize" button in the upper-right corner
    3. Click Tools > Extensions
    4. Locate the 1Password extension, and then click on the Trash icon
  • Thank you very much. Unfortunately with chrome I have the problem that sometimes the extensions tries to connect and is counting endless. Sometimes it works... In firefox the problem was the turned off websocket. After enabling everything worked. Is there something similar to chrome?

  • svondutchsvondutch

    Team Member

    Unfortunately with chrome I have the problem that sometimes the extensions tries to connect and is counting endless. Sometimes it works... In firefox the problem was the turned off websocket. After enabling everything worked. Is there something similar to chrome?

    Some anti-virus "solution" might be blocking the communications with the 1Password helper. Please read this:

  • Sorry for not answering soon (I was travelling). I don't know why it doesn't work anymore. I had no problems with chrome and firefox with the exception that the syncing between the main program didn't work (this was another question frome). After following the steps to solve the problem (deinstall xpi, deletion of the firefox file, reinstallation; analog chrome) I habe these not-connecting errors. I also deactivated my firewall, restarted the helper: nothing changed. I running sophos. Deactivating the service: sure? Don't I have a security problem? I did and firefox works now but chrome not.

  • DBrownDBrown 1Password Alumni

    We've heard reports of problems with the extensions for Chrome and Firefox, @Quentineire, but haven't been able to pin down the cause.

  • Yes, I tried and then (please look above) it worked with firefox. I'm happy. But I'm unhappy with chrome...
    Thank you very much for your always very fast answers! Great.

This discussion has been closed.