Copying a field from the 1Password app fails if done too quickly

When I need to copy a OTP password, I would click on the 1Password chrome extension, quickly type in the first few characters of the site to filter it instantly, click on the result in the list, and click on copy next to OTP.

What happens when I try to paste is that nothing from 1Password was copied into my pasteboard, but instead my previous clipboard from a different app was pasted.

I would try multiple times quickly, and it would fail every time.

However, when I wait 5 seconds before clicking copy on my OTP password, it would work.


1Password Version: 7.3.2
Extension Version: 4.7.5.90
OS Version: 10.15.3
Sync Type: Not Provided

Comments

  • Forgot to mention, this is a dropbox sync.

  • ag_anaag_ana

    Team Member

    Hi @komocode!

    I have taken the liberty to move your post to the Mac section, since I see that you are not using 1Password X ;)

    I followed your instructions but I could not reproduce this. I am also using the latest version of 1Password for Mac, while I see that you are quite a few updates behind now, so I wonder if that might be part of the issue.

    Can you try updating to 1Password 7.4.3 and see if that still happens to you? You might have to download and install manually from our website this time, since there was a bug in the autoupdater in an old version, which has since then been fixed.

  • I'll try 7.4.3 and I'll report back.

  • BenBen AWS Team

    Team Member

    :+1:

    Ben

  • Doesn't work. Just happened now. I tried twice to copy a 2FA code but it never copied. I grabbed my iPhone to quickly take a video clip, but the third time seemed to copy fine.

  • ag_anaag_ana

    Team Member

    @komocode:

    Thank you for the update. I still cannot reproduce this here. We will keep an eye out to see if we receive other similar reports.

  • I wanted to weigh in here as I experience this issue as well for several weeks if not months now.

    My workflow is as follows:
    In a terminal I need a OTP code for authentication. I will press the keyboard shortcut for the 1password floating windows to appear, move with the arrow keys to the element and within that element to the OTP entry and copy it via pressing enter. After which the floating 1password window disappears making me believe it copied successfully, but on using Command+v the last text I copied before is actually pasted.
    Order of key presses: Command+Option+\ Down Arrow Right Arrow Down Arrow Down Arrow Enter Command+v

    As I do this multiple times a day you can imagine I got fast at doing it. Start to finish I can do this easily within 2 seconds, even faster when I'm concentrated or not trying to look at the watch.
    I can reproduce it at any time and multiple times in succession.
    I tried to reproduce it with a different attribute (password or username) but then it always copied correctly (only tried it 5 times).

    System: MacOS, 1Password 7.4.3, active subscription with a cloud vault

  • ag_anaag_ana

    Team Member

    Thank you for sharing this information with us @dj5k, that's very useful! I still am not able to reproduce this here, but I have shared your message with the rest of the team to see if anyone is able to make this happen :+1:

  • ag_anaag_ana

    Team Member
    edited April 9

    @dj5k:

    We still have not been able to reproduce this, but I was told that we have an open issue to track feedback about this, since it was reported a couple of times before. I have added your experience to that conversation :+1:

    ref: dev/apple/issues#4013

  • Thank you!

  • ag_anaag_ana

    Team Member

    You are welcome :)

  • Hello,

    any news on the matter?

    Thanks

  • BenBen AWS Team

    Team Member

    @dj5k

    We have thus far been unable to reproduce the issue. We have about half a dozen customers who have reported similar experiences, but nothing that leads us to what may be causing it.

    Ben

  • Hey Ben, thanks for the response!

    If you have any leads on this or ideas, feel free to contact me for details or tests.

    Dominik

  • ag_anaag_ana

    Team Member

    Thank you @dj5k :)

  • dj5kdj5k

    Just an update: On version 7.5 it's still happening.

  • ag_tommyag_tommy

    Team Member
    edited May 13

    @dj5k

    Thank you for updating the topic. I wish I had news to report, but unfortunately, I do not.

  • jemmywjemmyw
    edited May 13

    I also experience this issue and it's very frustrating. In fact I did it just now as a test. Open 1password using the keyboard shortcut, type in a search phrase, click the one-time passcode field. The first time it did not copy. The second time it did.

    I don't think its a timing issue because it happens even without being speedy. It's more like a focus problem. The first time the field is clicked it isn't really focused and doesn't get the click event or something.

  • @ag_tommy I have a video of the issue happening if that would be helpful. If you email me directly I will send a link to the video. I created a test login for this, but I had to use the search to replicate it so I cannot post to the forum.

  • BenBen AWS Team

    Team Member

    Hey @jemmyw,

    It couldn't hurt. :) Please email it to us at [email protected] You'll get an automated email reply from BitBot with a support ID. Please post that ID here.

    Ben

  • @Ben the support ID is [#VGJ-33135-668]

    Note that it happened on the third attempt. Before each attempt I copied "test" to the clipboard first. Doing the search seemed to be the trigger, but I think that might just be coincidence. I recorded about 30+ attempts to copy and it happened a few times but that was the only one I got a clean recording of.

  • ag_anaag_ana

    Team Member
    edited May 15

    @jemmyw:

    Thank you! I confirm that I have managed to locate your email in our system :+1: We will take a look and someone will get back to your email as soon as possible.

    Thank you for your patience!

    ref: VGJ-33135-668

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file