Add on for Firefox 43.0 not working [Reinstall the Firefox extension to fix this]

Jay_FetchJay_Fetch
edited December 2015 in 1Password 4 for Windows

Yesterday my 1Password add on was removed by Firefox 43.0. It's no longer on the list of add ons and the add on on 1Password desktop no longer works either. Help!


1Password Version: 4.6.0.592
Extension Version: unknown
OS Version: win10
Sync Type: dropbox
Referrer: forum-search:Extension for Firefox 43.0 not working

Comments

  • Same here, please do fix it asap. It is very annoying not to have a direct access to password database via firefox.

  • We're sorry to hear that you're having this problem.

    This is happening because of the code signing requirement that Firefox introduced with version 42.
    Our Firefox extension has been properly prepared for this for a while and should work as expected.

    Can you please uninstall the Firefox extension from Firefox and reinstall it through the 1Password preferences?
    The current version of the extension is 4.4.3.

    Please let us know if this helps.

  • 1Password is gone after the Firefox 43.0 update on my Mac. Repeatedly get message that add-on could not be downloaded due to a connection failure.

  • brentybrenty

    Team Member

    @Aaron01106: You can download the current version of the extension from the AgileBits site, but you will need to be able to successfully make a secure connection. If you're getting some kind of error, be sure to check other software that may be breaking SSL. You can also try downloading the extension in another browser and then drag it to Firefox to install it. Please let me know how it turns out! :)

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @Aaron01106,

    Please follow the instructions here as you might have an AV interfering with the installation: https://support.1password.com/cannot-install-extension/#download-interrupted

  • 1password isn't working anymore in my Firefox. When I click on it, nothing happens. It is version 4.5.1. I tried uninstalling and reinstalling -- it didn't help.

  • brentybrenty

    Team Member

    Sorry you're having trouble! Are you using 1Password for Mac or 1Password for Windows? I ask because I see you've posted in the Mac category as well. Are you getting some kind of error message? Have you tried Mike's suggestion above?

This discussion has been closed.