Open and fill not working with 1Password 4 for Mac [⌘\ should still be working]

OS X 10.9.5
Chrome 47.0.2526.106
Browser extension installed.
Multiple sites attempted via Chrome plug in (1Password Mini); none will open new tab.
New tab WILL open automatically via the 1Password application itself but username and password will not fill.
I have not updated any software today.

1Password working fine this morning. Suddenly it won't open a tab in Chrome. Troubleshooting popup said it could be due to Chrome being in the middle of an update. No evidence anywhere that Chrome is updating...

Shut down and cold booted. Still doesn't open tabs in Chrome and troubleshooting popup doesn't pop up anymore, either. If I manually open a login page, Browser extension will fill the username and password if I click on the profile.

Thanks.


1Password Version: 4.4.3
Extension Version: 4.5.0.90
OS Version: OS X 10.9.5
Sync Type: Not Provided
Referrer: forum-search:not opening pages

AgileBits
There is a bug in the latest version of the 1Password Browser extension that affects 1Password 4 for Mac. The bug will stop you selecting an item from inside 1Password mini and having 1Password open a new tab, what we call go and fill. You should find opening the login page manually and then using the keyboard shortcut ⌘\ works. We are aware and hopeful to get this resolved soon.

Comments

  • Hi @SteveF,

    That's a good catch, thank you.

    We've had an open bug report on open and fill when initiated from the main 1Password 4 window that we need to address but this one is a very recent regression. I've identified the source of the problem and I hope we can get this fixed in a beta in the not too distant future. Sorry for the problems its caused, as 1Password 4 does things differently from 1Password 5 it slipped past our testing.

  • Same problem happened to me this morning. Using 1Password 4.4.3 on a Macbook Pro with Safari... everything is up to date. I used to be able to one-click the login (website) and the website would open via the extension. Now I have to open the 1Password app and login from there.

  • genemikegenemike
    edited December 2015

    Suddenly, just today, 1Password will not open a new tab nor open an url on an already open new tab.. If I find the url with a bookmark, 1Password WILL insert User and Password and launch. I have tried quitting and starting again 1Password and Safari. I have also restarted the computer. I have also tried resetting the Preferences to "Open a New Tab." I have not tried trashing the Preferences file


    1Password Version: 4.4.3
    Extension Version: ?
    OS Version: OS 10.8.5
    Sync Type: iCloud

  • New finding - It has to do with Safari. 1Password works as always with Firefox. But, I haven't done anything to change Safari. About a week ago, I downloaded a security update to Mountain Lion but 1Password has performed as expected since then.

  • I uninstalled the 1Password extension (which is Ver 4.5) and downloaded a new one and installed it. No effect - it still will not open a new tab nor insert the URL in a blank tab.

  • 1P extension 4.5.0 not working with Firefox 43.0.1. Fails to open a new tab and fill in the information. Suggestions please.

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @carpetboy,

    I'm using the same versions as you are and it works. What about visiting the site manually and pressing the 1Password icon to select an item to fill, does that work?

    Try restarting Firefox if 1Password was updated and Firefox wasn't restarted.

  • When visiting a site manually and pressing the icon the information fills properly

    A restart of Firefox (and a reboot) do not solve the problem of the tab not opening. More info iMac with 10.9.5; 1P 4.4.2

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @carpetboy,

    Wait, are you doing this on a Mac? This is a Windows topic, so I'm only tested it on Windows with 1Password 4.6.0.592.

  • Sorry. Yes on a Mac. Should I be on another thread?

  • Hi @SteveF,

    I'm mentioning your name just so you know I've altered the title of your post.

    @Dumpster: as you've discovered from this thread we learnt about this issue just today and I'm hoping we get iron this out soon.

    @genemike: I've merged your thread with this one as you were kind enough to confirm the version of 1Password that you're running. That was enough for me to know you're suffering the same issue. Sorry about that.

  • MikeTMikeT Agile Samurai

    Team Member
    This discussion was created from comments split from: Add on for Firefox 43.0 not working [Reinstall the Firefox extension to fix this].
  • MikeTMikeT Agile Samurai

    Team Member

    Hi @carpetboy,

    I've moved your thread to the Mac forum here, someone from the Mac team will follow up soon.

  • Greetings @carpetboy,

    Now that we know you're a 1Password 4 for Mac user I've merged your query in with a growing thread on this topic. There is an issue with the latest extension when used in conjunction with 1Password 4 for Mac and I'm hopeful we should get this fixed soon. Sorry for all the confusion.

  • Greetings @SteveF, @Dumpster, @genemike and @carpetboy,

    We released version 4.5.1 of the 1Password Browser Extension last night. Can you download please and see if it helps. If you can't see version 4.5.1 can you try downloading the beta version please.

    I'm hoping the fix will help you all.

  • I have it and it works like a charm! Something funny - in the downloads list, it was titled 4.5.1 but, in Safari preferences, it still says 4.5.0??

    Thanks!

  • Got 4.5.1 and it's working. Thanks for the help.

  • Hi @genemike,

    We did have a bit of a disagreement with the server but hopefully everything is working properly now. I can download 4.5.1 for Safari but we're still waiting for it to appear in the Safari Extensions Gallery for those that prefer it. It's the exact same version that you can download from our site though. Sorry for the blip!

  • Working for me... Thanks!

  • I'm happy! Thanks again!

  • Works correctly now. Thanks for getting on this so quick.

This discussion has been closed.