How do I delete vaults?

I recently signed up for 1Password family. I have migrated all of my data from my previous Dropbox synced vaults to my new Family vaults, and now I want to delete the old vaults. It looks like I can select a non-primary vault and then delete it using the Delete vault from the 1Password menu, but when I select the old Primary vault, the delete vault options is greyed out. How can I get rid of the old Primary vault?


1Password Version: Not Provided
Extension Version: Not Provided
OS Version: Not Provided
Sync Type: Not Provided

«1

Comments

  • Hi @formula155,

    From reading this thread it looks like you can remove the old Primary vault by starting fresh with 1Password. There is a guide here on how to do this:
    https://support.1password.com/starting-over/mac.html

    After launching again you would select the "Sign Into 1Password for Family" button.

    Before starting I would just recommend to backup all of the data the guide is asking you to delete.

  • Drew_AGDrew_AG 1Password Alumni

    Hi @formula155,

    Although the workaround that @rogerdodger suggested will certainly work, we've actually added a way to switch to "Families-only" mode without needing to start over/reset the 1Password app. If you'd like to try that, here are the steps:

    1. Delete your local secondary vaults from the 1Password app (it sounds like you've already done this).
    2. Go to 1Password > Preferences in the menubar, then select the Advanced tab.
    3. Un-check the option for "Allow creation of vaults outside of 1Password accounts".
    4. After reading the warning that appears, enter your master password (for the Primary vault) and click Delete Items and Vault.

    It's entirely up to you which method you use - either one will work fine. And as rogerdodger said, you should make sure you backup your data before doing this (just go to File > Backup in the main 1Password app).

    I hope this helps, but if you have more questions about that, just let us know. Cheers! :)

  • @Drew_AG,

    Thank you—your suggestion worked like a charm!

    Karen

  • Drew_AGDrew_AG 1Password Alumni

    Awesome! I'm glad my suggestion helped! :)

    In case anyone else is reading this and needs to delete a Primary vault after migrating to a 1Password.com account, we've made it even easier to do that - after copying/moving your data to your account vault, you can switch to the Primary vault and go to 1Password > Delete Vault... in the menu (if you have other local vaults, those will need to be deleted first before the Primary vault can be deleted).

    If you need more help, just let us know. Cheers! :)

  • Hey Drew, Thanks for your info! I have a follow-on to your last comment. I followed the procedure you outlined (I was migrating to a 1Password.com account), and deleted my Primary vault. Using just vaults under my account now. But it looks like now I can't create new Vaults in the 1Password app on my Mac, and a number of tabs on the Preferences pane have disappeared. Did I just somehow inadvertently loose a lot of functionality by deleting my Primary vault? How do I get those features back? Especially as I don't want a Primary vault (at least not of the form that I had before, where passwords in the Primary vault wouldn't sync to other 1Password instances on other machines, synced using my account).

    Thanks, Justin

  • ag_kevinag_kevin Junior Member

    Team Member

    Hi @justinrr ,

    The tabs that no longer appear are for features that aren't relevant to account vaults. WLAN server and sync are gone because sync of account vaults is automatic through 1Password.com. So rest assured, you haven't lost any functionality.

    Cheers,
    Kevin

  • 1 Password > Delete Vault does not exist in my menu.
    I switched to my local vault in order to delete it, but your advice does not work. It worked fine on my Macbook by un-checkingLocal Vaults in Preferences > Advanced.
    This is not possible on my iMac (greyed out)
    Any advice?

  • rudyrudy

    Team Member
    edited July 2017

    @JodiSte01,

    Thanks for writing in with your question. If you look at the main window and it indicates in the top left that you are in All Vaults then that would be why it doesn't show the delete vault menu item. You need to switch to the specific vault you want to delete in order to have access to that menu item.

    Rudy

  • Hi Rudy — I have 2 vaults, primary and a secondary. I've switched to the secondary vault, which is almost empty (vs. the primary which has over 400 items). There is no option to delete this vault. Any suggestions on what to check or do?

    Andy MacBride

  • brentybrenty

    Team Member

    @Andy_MacBride: You can delete any secondary local vaults from the 1Password menu once they're selected:

    Only once any secondary local vaults are removed can you disable local vaults in Preferences > Advanced (which will remove the Primary vault as well).

    I hope this helps. Be sure to let me know if you have any other questions! :)

  • Here's what mine looks like:

    I was able to delete the "Robin" vault by logging into 1Password's web version. Couldn't find a way to do that from within the application.

  • LarsLars Junior Member

    Team Member

    Hi @Andy_MacBride -- as brenty mentioned up above, you can delete any vaults you have write access for by selecting that vault in the vault menu (in other words, don't leave it on "All Vaults," but instead choose the vault you want to delete, so 1Password is showing only items from that vault). Then, from the 1Password menu, choose "Delete (name of vault) Vault," and you should be good to go. You can test this if you like, by creating a new vault and then deleting it in this manner.

  • Support folks — I just created a test vault, it's the selected vault, just like just like the screen shot above with "Robin" selected. I hope you can agree that there is no option to delete that vault.

    If I log into https://my.1password.com/home, I can select "manage" and then delete the vault. That's the only way I've found to do this, the option to delete from within the app doesn't exist for me.

    I'm running 6.8.1 on Mac OS 10.12.6. If you there's user error here, I can't see where. If someone would like to get eyes on this with a screen share, that might be the best way to clear up any confusion.

  • LarsLars Junior Member

    Team Member

    Hi @Andy_MacBride -- sorry for the trouble. I should've made it clear earlier that the deletion of 1Password.com vaults can indeed only be done via 1password.com, not from within 1Password for Mac. You can delete any local vaults you have this way, but not 1password.com vaults. Sorry for the confusion.

  • Got it, thanks Lars.

  • LarsLars Junior Member

    Team Member

    You're quite welcome, @Andy_MacBride -- drop by anytime!

  • I am trying to delete old secondary vaults. I tried being in All Vaults, the Primary Vault, and the various secondary faults, and the option still remains grayed out. What else can I do to delete old vaults? Thank you!

  • LarsLars Junior Member

    Team Member

    Welcome to the forum, @jennys! If you've got 1Password for Mac and you're working with local (standalone) data, you should be able to delete vaults by selecting the vault in the Vault Menu (top left of the main 1Password window) - just click there and select the vault you want to delete. Then go to the top left of your Mac's screen and choose 1Password > Delete (name) Vault. If the vault is selected, the option to delete it should not be grayed out. Let us know how that works for you!

  • Thanks, @Lars. I'm not sure if I have local/standalone data. The vaults were ones I set up for past contractors who work for me. The vaults were on Dropbox. The vaults have been deleted on dropbox but they still show up in 1PW.

    I don't have the option to > Delete Vault.

  • LarsLars Junior Member

    Team Member

    @jennys - OK, so you (or someone) deleted the Dropbox sync keychain? That will certainly disable sync, but 1Password has its own internal SQLite database, which is what you see when you unlock it with your Master Password. Deleting the sync keychain won't delete the vault in 1Password for Mac.

    To do that, you should see the Delete option right underneath the "Switch to Vault" command in that menu, like this:

    If you can't see that, then you may not have switched to the vault you want to delete. To do that, you'll need to do so using the "Switch to Vault" command in the screenshot you posted. See it? Hovering on that should bring up a list of the vaults you've got, at which point you can select one you wish to delete. Then open that same menu again, and see whether the Delete command is visible as in my example.

  • That did it! Thank you so much @Lars ! I don't like digital clutter, so it's great to finally get rid of those old vaults! Much appreciated!

  • LarsLars Junior Member

    Team Member

    @jennys - Great! I'm glad I was able to help you get squared away. I don't like clutter either (though you'd never know that from the looks of my house -- I blame teenagers. ;) ). Let us know if there's anything further we can do to assist you, and have a Happy New Year!

  • rogersmjrogersmj Junior Member

    Hi 1Password team -- I'm trying to delete my old vaults too, after having originally bought 1Password waaaay back in 2008(!) I finally upgraded to a family plan today. I got all my stuff transferred into the new online vaults, but I can't delete the old vaults from my Mac.

    I have read all the instructions above and I must be missing something. I am definitely in my old "Primary" vault (not in All Vaults). I turned off syncing with Dropbox in the settings, and deleted the Dropbox data. Yet throughout all this the Delete Vault option remains grayed out for me:

  • brentybrenty

    Team Member

    @rogersmj: Lars was working with someone to remove secondary vaults, but you appear to have the Primary selected. You can only remove that after all secondary vaults have been removed, and then only by disabling local vaults in 1Password Preferences > Advanced. Does that help? :)

  • rogersmjrogersmj Junior Member

    @brenty -- oops...that was it. I still had another local vault. I didn't realize I had to delete it first before deleting the primary. All better now. Thanks!

  • LarsLars Junior Member

    Team Member

    @rogersmj - great! Glad to know you got it all sorted out. :)

  • Hi, in 7.0.3 I have a secondary vault that refuses to be deleted! It shows up under Vault/Delete Vault but after typing the vault name the delete button is still grayed out? Any ideas?

  • LarsLars Junior Member

    Team Member

    Welcome to the forum, @stavon! The only things that could cause that (that I can think of off the top of my head) are: 1) you're typing it wrong or 2) there's a permissions issue. I can't imagine the latter would be the case, but I suppose anything's possible. I'd check to make sure you don't have a 0 instead of an O, or something like that, though.

    One other possibility is: are you sure it's a secondary vault? If it's your Primary, that won't work; you'll need to visit Preferences > Advanced and UN-check the box marked "Allow creation of vaults outside of 1Password accounts."

  • JDWJDW Junior Member

    I am using 1Password 7.0.7 in August 2018 with a standalone license. I read through this thread but none of the advice helps. Preferences > Advanced > Allow creation of vaults... is check marked and grayed out no matter what I do. I have 3 vaults. I wish to keep 1 and delete the other 2. It's impossible to do this. Please tell me how.

    Please also improve 1Password 7 in a future update to make this vault deletion process easier. For example, I should be able to right-click on a vault in the left sidebar and be given Edit Vault... and from within that dialog be able to delete the vault, which is something you don't allow us to do now.

    I look forward to your reply.

    Thank you.

  • LarsLars Junior Member

    Team Member

    @JDW - sorry for the trouble! The reason that box is grayed out is because you have three vaults. 1Password - by virtue of how it works - relies upon ONE password to open all of your vaults. How can this be, when each vault was given its own password when you created it? Because your first vault is set up as the Primary vault, and other vaults are secondaries. The "keys" for the secondary vaults are kept inside the first, so that you can unlock everything with just your one Master Password.

    This also means that you cannot delete your Primary (initial) vault in the same way you do other vaults. If the vault you want to delete is not your Primary, follow these steps:

    1. Switch to the vault you plan to delete, using the vault menu in your menubar: Vault > Switch to Vault > (name of vault)
    2. Click the Vault menu item in the menubar a second time and choose Delete (name of vault) Vault.

    If you have only the Primary vault, you can then delete it by the method you described (if that's what you want to do), but secondary vaults must be deleted in this way. Hope that helps! :)

«1

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file