Can't enable Fingerprint unlock: Keystore operation failed

sanekladsaneklad
edited January 2018 in Android

Fingerprint Unlock unavailable.
java.security.ProviderException: Keystore operation failed

Huawei Mate 10 Pro with multiply users and fingerprints (not native, PrivateSpace function turned on)
When I had 1 user and fingerprint - FU worked.


1Password Version: 6.7
Extension Version: Not Provided
OS Version: Android 8.0
Sync Type: my.1password.com

Comments

  • periperi

    Team Member

    Hi @saneklad. Thanks for reaching out!

    I'm not very familiar with Huawei's Private Space feature. Is 1Password installed in the same user account with the fingerprint you're using?

  • Had the same issue. Try going into the "nexus imprint" / "fingerprint" settings of android OS and changing some stuff there - i.e. display the name of the imprints, change it, etc. For me no re-setup of the imprints was necessary.
    Afterwards, back in the app everything worked again..

  • periperi

    Team Member

    Hi @icyerasor. Thanks for chiming in with this. I'm glad to hear everything is working well for you, and maybe others will find this helpful. :)

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file