No private channel / user support for Slack Integration

The first iteration of the Slack support in 1pass for Teams allowed me to send messages to an individual and/or private channel.

Now that I can't send to the private #security-alerts channel, I can't use the integration. I don't want to create a new channel and I can't make this channel public. Any suggestions? The v1 integration allowed me to do this...


1Password Version: Teams
Extension Version: Not Provided
OS Version: Not Provided
Sync Type: Not Provided

Comments

  • rickfillionrickfillion Junior Member

    Team Member

    Hi @stmyers,

    You're right, when we switched from using the webhook approach to a true Slack app we lost that functionality. We're sad about that too, and we're hoping that we can do better somehow. As of right now there is no workaround, unfortunately.

    Rick

  • ondalimeondalime
    edited March 2018

    hi @stmyers

    Margeau from 1Password gave me the good news:

    Posting Slack notifications and alerts to private channels is now supported again. To get it to work you’ll need to disable and re-enable your integration in the account interface—it requires extra authorization permissions.

    Tested, working. 1Password Slack integration v2 supports private channels again! Great. Thanks a lot, guys!

    Cheers, Philip

  • brentybrenty

    Team Member

    Thanks for taking the time to update the thread! So glad it's there for you and everyone else to use now. Cheers! :chuffed:

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file