I get Unable to reach our server when trying to save password

13»

Comments

  • @dteare Yep! Will see if I can replicate this issue as well and provide logs.

  • dtearedteare Agile Founder

    Team Member

    Yup! Looks like you have the same settings I had when I recreate this issue. Thanks for sharing.

    By the way, the lock settings for 1Password for Mac have no effect on 1Password X. They're completely independent.

    We'll look into this and try to get a fix out soon.

    ++dave;

  • How do I stop getting email notifications for this forum topic? I can't see where I can turn them off - can someone advise? Thanks

  • sjksjk oversoul

    Team Member

    Hi @Swishy888,

    Whether or not you get forum notifications depends on how you've configured Notification Preferences, like I described over here.

    The software for this forum doesn't have an option to disable notifications for specific discussions, which would be the most desirable way to do it. An alternative is to bookmark only ones you want notifications for, with at least Notify me when people comment on my bookmarked discussions enabled.

    I hope that helps even if it's not optimal.

  • edited October 15

    Woke up this morning and GOT ONE! Using Firefox 62.0.3, 1Password X version 1.11.0. Hope I captured the right log:

    [Show/hide message details.] Unchecked lastError value: Error: Could not establish connection. Receiving end does not exist. bg.js:346
    [_request] Request "/api/v2/vault/gzjh7kn6e5iweldbh5m5ap2htm/119/items" failed: ServerError: "Authentication required."
    tmoz-extension://5265c375-705f-f541-92f8-193e2f9a6138/background/background.js:36:66710_handleQwestErrormoz-extension://5265c375-705f-f541-92f8-193e2f9a6138/background/background.js:36:264179fmoz-extension://5265c375-705f-f541-92f8-193e2f9a6138/background/background.js:29:759612umoz-extension://5265c375-705f-f541-92f8-193e2f9a6138/background/background.js:29:759299mmoz-extension://5265c375-705f-f541-92f8-193e2f9a6138/background/background.js:29:618362mmoz-extension://5265c375-705f-f541-92f8-193e2f9a6138/background/background.js:29:618300smoz-extension://5265c375-705f-f541-92f8-193e2f9a6138/background/background.js:29:617835 background.js:29:576127
    Unable to save item, running syncer and retrying... background.js:36:440501
    [_request] Request "/api/v1/overview" failed: ServerError: "Authentication required."
    tmoz-extension://5265c375-705f-f541-92f8-193e2f9a6138/background/background.js:36:66710_handleQwestErrormoz-extension://5265c375-705f-f541-92f8-193e2f9a6138/background/background.js:36:264179fmoz-extension://5265c375-705f-f541-92f8-193e2f9a6138/background/background.js:29:759612umoz-extension://5265c375-705f-f541-92f8-193e2f9a6138/background/background.js:29:759299mmoz-extension://5265c375-705f-f541-92f8-193e2f9a6138/background/background.js:29:618362mmoz-extension://5265c375-705f-f541-92f8-193e2f9a6138/background/background.js:29:618300smoz-extension://5265c375-705f-f541-92f8-193e2f9a6138/background/background.js:29:617835 background.js:29:576127
    [action/auth#createNewContext] Error: "Missing current user"
    vymoz-extension://5265c375-705f-f541-92f8-193e2f9a6138/background/background.js:36:324336 background.js:29:576127
    k/e[t]
    moz-extension://5265c375-705f-f541-92f8-193e2f9a6138/background/background.js:29:576127
    rt<
    moz-extension://5265c375-705f-f541-92f8-193e2f9a6138/background/background.js:36:69468
    g
    moz-extension://5265c375-705f-f541-92f8-193e2f9a6138/background/background.js:9:29911
    Failed to save login: Error: "Missing current user"
    vymoz-extension://5265c375-705f-f541-92f8-193e2f9a6138/background/background.js:36:324336 background.js:29:576127 
    
  • dtearedteare Agile Founder

    Team Member

    Woot! Thanks for the logs, @boberonicus. That's exactly what I needed.

    @beyer and I found the issue. Turns out it was indeed related to sessions timing out, which normally manifests itself when autolock is disabled. The thing that made this especially hard to track down was the error would only happen after your session timed out for a second time.

    We just released beta 1.12.6 which has a fix for this. Please put it through it's paces and let us know how it goes.

    //cc @bcatubig

  • Can you link to the beta 1.12.6 Firefox add-on?

  • brentybrenty

    Team Member
    edited October 17

    @boberonicus: There is no beta for Firefox. It's something we'd like to offer in the future, but for the time being it's only for Chrome (-based browsers). Sorry. :blush:

  • Thank you so, so much for fixing this. 1Pass is such a good app. This issue plagued me for months but I stuck around because everything else is great. I haven't experienced the problem yet since installing the beta version.

  • dtearedteare Agile Founder

    Team Member

    Thank you so much for saying so, @purienne! ❤️

    @boberonicus: We actually have an internal Firefox beta but it's not something we share externally very often. I plan on making this public once we polish a few remaining rough edges.

    ++dave;

  • edited December 5

    @dteare I've been having this same issue and (at least in my case) I think it may have to do with enabling Two-Factor Authentication. After enabling it on another machine, I was able to sign into my 1 Password account without entering the 2FA code on a different browser, but kept getting the 'Unable to reach server' message when trying to save a Login, after uninstalling and reinstalling the extension, it asked for the 2FA code when signing in, and now I am able to save correctly.

  • Hello @CCWSupport,

    I believe the team have identified a couple of regressions this week that could be the cause of this not being completely squashed. My hope is we'll see the fixes in a new copy of 1Password X soon.

13»

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file