Not submitting login form automatically [must be enabled in Preferences > Browsers]

SystemSystem

Team Member
This discussion was created from comments split from: Feedback on the new 1Password mini.

Comments

  • hazmathazmat Member

    @Narius Are you sure Submit Logins didn't get unchecked?

  • NariusNarius
    edited May 2018

    @hazmat @brenty Ok. My first thought was: "Well that was embarrassingly simple" but then when I went to turn it on, I saw the popup that required me to authorise - so I actually had to go through the steps to make that happen. Maybe that was in the releas notes when I agreed to the update, (and it was my bad that I didn't read them) or maybe it wasn't. If not, it might be helpful to remember to point that out to simpletons like me who liked the way it worked.
    Thanks for all your patient help.

  • hazmathazmat Member

    @Narius As long as you got it working! I actually keep that off, because sometimes things don't get filled out as expected, so I like to manually submit once it's filled in.

  • brentybrenty

    Team Member
    edited May 2018

    @Narius: Thanks so much for the video! I appreciate the illustration, and you bringing this up in the first place. I've split this off into a new discussion as I suspect it will come up for others as well.

    There are some changes in 1Password 7 in this area, especially if you were not previously using the Mac App Store version. 1Password 7 — even the AgileBits Store version — will be sandboxed. The Mac App Store version has been already, and that means we have to use a different method for autosubmit: the "Automatically sign in after filling usernames and passwords" option in 1Password Preferences > Browsers will, when checked, (attempt to) install a script to perform this function. If you click the checkbox and then "Continue" and the box stays checked with no other interaction required, you're good. While some websites pose a challenge, even if 1Password is not able to automatically submit the login form after filling you should be able to do so, without clicking, by simply pressing the Return key. Otherwise autosubmit should work for you in most cases, and we definitely want to know about where it doesn't to see if there's something we can do to help.

    Unfortunately we've also seen some cases where things can get into a bad state and 1Password has difficulty accessing the appropriate location. If you find that the checkbox does not stay checked, or that you're prompted to select the location and it doesn't seem to work, restart your Mac and try this:

    1. Open 1Password
    2. Go to Preferences > Browsers
    3. Click the "Automatically sign in after filling usernames and passwords" checkbox
    4. Click the button to continue
    5. In the window where you're asked to select the folder, press ⌘ ↑ to go up one level to the parent folder
    6. Single-click the "Application Scripts" folder to select it, and click the button to "Select Script Folder"
    7. You'll get an error; ignore it
    8. Click the "Automatically sign in after filling usernames and passwords" checkbox in Preferences > Browsers
    9. This time, in the window where you're asked to select the folder, click the button to "Select Script Folder"
    10. You may still get an error, but ignore it; you should have "Automatically sign in after filling usernames and passwords" checked now

    Either way, I hope the explanation helps shed some light on things and get it working for you if it wasn't. Be sure to let me know if you have any other questions. :)

    ref: apple-1173, apple-1174

  • Thanks @brenty. As you can see above, I ended up going the Scripts route, though the first time I tried, it looked as though the preferences checkbox "took" and was working without a popup. Turns out not, so my second try worked.
    Glad I could help. Gotta love ScreenFlow, when a picture paints 1000 words.

  • brentybrenty

    Team Member

    Absolutely! :chuffed::+1:

This discussion has been closed.