Reason why 1Password 7 requires mac OS 10.12

Hi, is there a technical reason why 1Password 7 for Mac requires at least 10.12, ie. do you need operation system features that only 10.12+ provides?
I'm currently running 10.11 and can't upgrade because of the old hardware and my Mac is running 1Password 6 just fine.


1Password Version: Not Provided
Extension Version: Not Provided
OS Version: Not Provided
Sync Type: Not Provided

Comments

  • JadCJadC 1Password Alumni

    Hi @Manaburner, good question!

    This is due to technical restrictions in macOS 10.11. In particular, parts of the app are written in Swift, and we needed a version of Xcode that would be able to compile and debug those snippets of code.

    If you still need to upgrade your machine to the latest version of 1Password 6 (6.8.9), you can still download it here.

    I hope that was informative :).
    Jad

  • Yes informative. And sad because I don’t see me buy a new Mac in the near future because their lineup is currently pretty meh. ;)

  • LarsLars Junior Member

    Team Member

    @Manaburner - well, you're a regular around here. We'll leave the light on for you. :)

  • Thx @Lars There’s still The Windows Version for me so I’m not completely off the 7 train

  • rudyrudy

    Team Member

    @Manaburner,

    The Swift vs Xcode was the clincher here, but there were a number of other reasons such as the auto layout implementation on 10.11 (and even 10.12) not being quite up to snuff. 10.14 will I'm sure pull us forward again.

    Rudy

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file