Filling in Chrome


  • Hi, I am having the same problem but I am using Google Chrome, also tried Safari. Have tried removing extensions from Chrome and reinstall, shutting down mac and restarting, nothing seems to help. Can't get it to work on Safari either. I prefer to use Chrome, so a solution would be appreciated.

  • brentybrenty

    Team Member

    @spatz1805: Can you be more specific? I'm betting you're not using a beta of 1Password, as there isn't one currently, and the Safari app extension was pulled a while ago and wouldn't affect Chrome anyway. What are the exact OS, 1Password, browser, and extension versions you're using, and what's the URL for the site where you're having trouble?

  • Hi Brenty, I am using the update of 1password7 which appeared on my mac yesterday on my mac, so not sure if it is a beta or full version.
    My OS is 10.13.4. All URL's on my saved logins aren't working. Should I go back to 1password6? And if so, how do I go about this?

  • Hi Brenty, sorted it I think. I have to open Chrome and then 1password and it will then auto open and fill in. But it will not open Chrome and then do auto open and fill like it did in the versions before. Anyway, I at least can use it in a roundabout way.

  • brentybrenty

    Team Member

    @spatz1805: Do you have Chrome set as the default browser in System Preferences? If not, You definitely won't be able to open logins there from 1Password. I'm glad that workaround helps, but we can certainly see if there's a solution to the difficulty you're having. :)

  • yes my default browser is set to Google Chrome app

  • Greetings @spatz1805,

    When you say open Chrome there are two scenarios I can envisage.

    1. Chrome is not running. Chrome will need to be launched before 1Password can initiate open-and-fill.
    2. Chrome is running but does not have an active window open. 1Password will need to open a new window before it can start open-and-fill.

    We're aware of an issue with 2. where 1Password isn't opening a new window but if you quit Chrome completely and then try open-and-fill do you find it works?

    ref: apple-1113

  • On older versions I would go to my logins, click fill and open and google would open showing the website and log me in. Google is always on the bottom as well as 1 password. Now I have to open google first then clock the fill and open in 1Password for the website I want to login in to. It is not a problem as such, but it took me while to work it out. I uninstalled and re installed 1 password73 times, as well as removed and added extensions and shut down Mac, then trying to open one of my logins the ‘old way’ and nothing would happen. Only discovered by accident that now I had to open google first. Thanks for your help. I am happy.

  • Greetings @spatz1805,

    When you say Google is always on the bottom do you mean scenario 1, where Chrome is running but has no active window? I apologise for returning to the question but it's important to make sure we agree on the issue. I would be sad if we left it as is and it turned out you were having a separate issue that we weren't aware of yet.

    1Password 6 did handle both scenarios correctly and this is something we will need to correct in 1Password 7.

  • yes I did mean chrome is running but not an active window.

  • Hello @spatz1805,

    Thank you :smile: That does mean its the bug we're aware of and do need to fix. Thank you for confirming.

  • Brilliant, glad to help. Looking forward to the fix.

This discussion has been closed.