Disabled beta but still getting automated beta updates

I asked about this previously:
https://discussions.agilebits.com/discussion/94374/how-do-i-disable-the-1password-7-include-beta-builds-option#latest

As recommended, I turned off Automatically check for updates. I presumed that the next update I would receive would be a stable channel update. (Perhaps a mistaken presumption on my part?) Instead, the next thing that happened a couple weeks later was another beta update that downloaded and installed itself automatically. This is an actual screen cap as it happened (I deleted background imagery showing other open programs):

So how do I really disable beta updates? Do I have to downgrade to the current stable version? If I do that, will all my existing data be preserved?

Perhaps the next time you invite ordinary customers to join your beta program, you might consider explaining that while it's trivially easy to join the beta, it will take more effort to leave it. That way, your customers can make a more informed decision about whether to proceed.

Thanks.


1Password Version: 7.1 Beta-4
Extension Version: Not Provided
OS Version: 10.13.6
Sync Type: Not Provided

Comments

  • brentybrenty

    Team Member

    @Toshen: You're getting beta updates because you're running the beta. If you Trash it and install the stable release, you should be able to disable betas in Preferences > Updates and stop being prompted for them. :)

  • rudyrudy

    Team Member

    @Toshen,

    This has been fixed in the 7.2 betas, it now correctly shows "include beta builds" as checked and not modifiable while running the beta.

  • Thanks for the update.

  • brentybrenty

    Team Member

    Sorry for the confusion there. If you have any issues with future betas be sure to let us know. :)

  • Hello

    I have followed your instructions:

    • removed the beta version of 1Password
    • downloaded the latest stable version 1Password 7.2.1
    • installed it

    But i am still unable to deactivate the option Include beta builds in the preferences

    iMac Late 2009, macOS 10.14.0, 1Password 7.2.1

  • rudyrudy

    Team Member

    @Laur59,

    Yes, the fix for the checkbox not being uncheckable is coming in 7.2.2, which has not yet been released.

  • I'm on the 7.2.4 release (just re-download and install from the website, and I'm not able to uncheck the beta channel option.

  • AGKyleAGKyle AgileSupport

    Team Member

    @Irvin Is "Automatically check for updates" unchecked?

    If so please check that option, then uncheck the beta option. You'll want to leave "automatically check for updates" enabled, but you can disable the other two if you wish. This way you're at least notified when a new update is available.

  • @AGKyle great, it works. Thanks.

  • AGKyleAGKyle AgileSupport

    Team Member

    @Irvin Great to hear that helped. Please have a wonderful weekend!

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file