Chrome Extension No Longer Works

SevaliSevali
edited December 4 in 1Password 4 for Windows

Up until recently the extension was working. Yesterday when I opened Chrome, I was asked to authorize the browser. I confirmed that the 6 numbers that were in the little window were the same as what was displayed in the browser. I have had this happen every great once in a while and once authorized things worked just fine. However, this time when I went to use the extension, it didn't work. It shows nothing when I click on it. So I began to see if others had this problem.

I found a suggestion by @bundtkate to check the Help | Advanced | Use Native Messaging Protocol setting. I did and found that the option wasn't checked. I've never changed this option, because I don't know what it does. So I changed the option from "Use Web-socket Protocol" and opened Chrome (it was closed), I didn't get the authorize message. But the extension still doesn't work. So I went back to the 1Password v4.6.2.626 and discovered that I could literally do nothing in the program. It was as if the mouse was wanting to be somewhere else, i.e. inside the Chrome browser. I closed 1Password and restarted it. When I attempted to type in the password in 1Password, the cursor actually moved out of 1Password and to the edit field in the Chrome browser. I also noticed that anything (I mean this quite literally) with a popup stopped functioning as it normally did. I could not keep the popup open to click on anything and my mouse acts strange (like it is really slow to respond to movement). I'm not sure how all of this is related, but somehow it is. Because when I changed the option in 1Password back to the Web-socket Protocol everything goes back to normal. I should add that the strange things I mention only occur when Chrome is open. When Chrome is closed, things go back to working normal.

I have re-installed 1Password with version 4.6.2.625 and updated it to 626 and reinstalled Chrome and I have removed and reinstalled the extension. Nothing has worked. There were two things that I have done to my computer recently that Windows 10 told me I needed to fix: 1) something concerning the firewall wasn't enabled, so I enabled this and 2) something concerning Windows Defender wasn't updated, so I updated it.

Comments

  • I have the same problem as the original post. I did, 'Help > Advanced. Make sure "Use Native Messaging protocol"'. Once I did this, I could not have 1Password for Windows open at the same time as Chrome. All keyboard traffic was sent to Chrome. I also wasn't able to open any menus in 1Password for Windows. It looked as if the mouse was constantly busy somewhere else (Chrome?) and the menus quickly closed after I tried to open. When clicking on the 1Password extension in Chrome, nothing happens. Yesterday or so everything worked fine. I've rebooted my computer and re-installed the extension.

  • brentybrenty

    Team Member

    @Sevali: None of that relates to what the original post says. I've never heard of what you're describing, assuming I'm understanding you correctly. What did you do in the first place, before all of this happened? I can't imagine you've had Native Messaging disabled for over a year and just enabled it now, but regardless it would be helpful to know what was happening in the first place that prompted you to go poking around and changing things, and the exact steps steps you took leading up to your comments here. Let me know!

  • SevaliSevali
    edited December 4

    @bentley : My apologies, it seemed to me that the issue was very similar as the original post. I will create a new thread.

  • SystemSystem

    Team Member
    This discussion was created from comments split from: Chrome Extension and 1Password 4.
  • brentybrenty

    Team Member

    @Sevali: No worries. Thanks for the additional details. Please try the following:

    1. Close your web browsers and 1Password
    2. Open Windows File Explorer and enter the following in the address bar: %LOCALAPPDATA%\AgileBits
    3. Move the OPX4.auth file to your desktop
    4. Restart 1Password, unlock and then open your browser, see if it works better now.

    Let me know.

  • SevaliSevali
    edited December 4

    @bentley That fixed it. Thank you so very much.

    On a side note, this also fixed the Firefox browser problem as well. In Firefox, the icon looked as though it was disabled (gray), but it was enabled. That hadn't worked for a very long time (year+).

  • brentybrenty

    Team Member

    Great! Thanks so much for the update -- and for the detailed description that helped me understand what was going on there. Glad that helped get 1Password re-connected with Firefox. Hopefully you don't run into any further issues, but if you do, get in touch right away. We're here for you! :chuffed:

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file