Can't type into the Safari plugin

bazcurtisbazcurtis Junior Member


I have running Safari 7.0.1 with plugin version 4.0.1. I have uninstalled it and reinstalled it and I still can't type into the name box when I try and save an entry. Anyone else seen this?

Best wishes



  • MeganMegan

    Team Member

    Hi @bazcurtis,

    I'm sorry to hear that you're having trouble with the Safari extension. That is a weird problem. Could you please take a screenshot of what you are seeing? There are instructions on how to take a screenshot here: You can save the image to a service like Dropbox or Droplr and include a link in your reply.

  • MartySMartyS AgileBits Customer Care (retired)

    I had the exact same condition happen to me yesterday — it was as if the overlay asking what to do with the information wasn't able to get fully forward although it was visually very front-and-center on the screen.

    Unfortunately now I have no idea what the conditions actually were at that time... was I actually saving credentials for a new Logins item or had I changed credentials for an existing one? I could not say as I did one of each yesterday. :(

    However, as fate would have it... I can reproduce it! I tried to manually save a Logins item on this very web page and this is what I get:

    I can click on the top selector but I cannot type anything into the name field. If I click the button beside the name field I get this:

    It's as if the CSS is messed up. And notice how the overlay isn't highlighted at the top the same in the two images. All other fields and selectors seem to do what they are supposed to but the name field remains unchangeable.

    I'm running 1Password 4.2-BETA-2 with extension version 4.1.0.b2 in Safari.

  • sjksjk oversoul

    Team Member

    Hey @MartyS,

    So far this bug hasn't cooperated with my attempts to reproduce it. Closest I've come is seeing the auto-save window incorrectly displayed once, sort of like a scrunched version of your second image, with 1P 4.1.3/4.0.1 main/extension in Safari 7.0.1. No issues with 1P 4.2.BETA-2/4.1.0.b2.

    Did you initiate the manual save from 1P mini on this forum's Sign In overlay window?

    Is this problem 100% reproducible and does it still happen after toggling the disclosure triangle in the auto-save window? Have you tried it with Chrome and/or Firefox? Any ideas how to trigger it here are appreciated. :)

  • MartySMartyS AgileBits Customer Care (retired)

    Of course it's working fine for me now, @sjk. :D

    For my failures I was not trying to save from the overlay: I was already signed in, reading this thread and typed something into the "Leave a Comment" field. I then clicked on the extension's icon and navigated to Save new Login.

    Have you tried it with Chrome and/or Firefox?

    What is this "Chrome" and "Firefox" you speak of? =)) Sorry I can't be of more assistance this time but I'll let you know if that changes.

  • sjksjk oversoul

    Team Member

    I hope you don't mind this is eluding you now, @MartyS. :)

    Thanks for posting steps you used when it did happen. I'll confirm it's intentional that Save new Login is active in text boxes when only a website field will be saved.

    Safari has been my preferred browser on OS X for awhile.

This discussion has been closed.