Fill Issue with Post Office Credit Card website

MeganMegan

Team Member
This discussion was created from comments split from: [Working on a fix] Saving Santander bank accounts....

Comments

  • stukeystukey
    edited June 2014

    Hi @JasperP and @Megan‌

    I am seeing similar problems with the Post Office Credit Card website (UK). Since updating to version 4.2.0 of the Safari extension, 1PW no longer fills or submits the user name and password for this website. I have also tested with v4.2.1 of the extension and the problem still exits. This website has a two page log-in process, similar to Santander Bank mentioned above. It has been working fine for the last 12 months but stopped working after I upgraded to 4.2.0 of the extension.

    I changed my password on the same day that I installed v4.2.0 of the extension. At that point it appears 1Password updated the pin field as a 'password' type field and that's when the fill functionality stopped working. If I manually edit all of the web form detail fields in the login and remove the username and password types from all fields - then 1Password works and fills-in both the 1st and 2nd login pages correctly. However 1PW then shows a heartbleed vulnerability alert for the login - presumably because the username / password fields at the top of the login are empty (but they do appear in the web form details).

    What I've found is that if any of the fields are listed as a 'username' (person icon) then the 2nd Post Office login page fill doesn't work and if any are listed as a 'password' (key icon) then the 1st login page doesn't fill! But if those fields types aren't set properly then there's no way to get rid of the vulnerability alert and the top username and password information isn't displayed properly!! Very frustrating. This was all working fine prior to changing my password on the 28th May and/or updating to Safari extension 4.2.0.

    I have tried recreating the logins from scratch but that doesn't help. I also tried downgrading to v4.1.0 of the Safari extension and the problem went away - 1PW successfully filled and submitted the login details. But with 4.2.1 it does work at all.

    Hope you can help.

  • @Megan and @sjk I am seeing a similar issue on the UK Post Office Credit Card website. I have reported to support @ agilebits but so far they have just told me that "…there were major changes in Safari extension 4.2 and it's unlikely that agilebits will be able to fix it". Which is disappointing :-S

    I have tested with 1PW Safari extension 4.1.0 and it works fine. But it fails under 4.2.1. So it appears there is a bug in the 4.2.1 release of the extension as far as I can tell. 1PW completely refuses to fill in the fields on this website under the new version of the extension if either of the fields in the login are set with either 'Username' (person icon) or 'Password' (key icon) flag in the Web Form details section.

    If you remove the 'Username' or 'Password' flag from the web form fields then the new 4.2.1 extension correctly fills the websites. So the work-around is to manually remove the field types in the login but then the main 1PW app constantly shows the heartbleed vulnerability alert for the login - presumably because it thinks that the password field is empty? In addition this causes 1PW not to display the username or password fields at the top of the login and in the view list.

  • MeganMegan

    Team Member

    Hi @stukey‌

    I'm so sorry to hear that you're having trouble with the new extension and the UK Post Office Credit Card site. I was able to track down your email in our system using the email address attached to your forum account. I see that Kyle has been helping you with this already. You're in good hands!

    .

  • Update login does not always show up, well did not show up, before i just upgraded to the latest beta. I will watch to see if this is fixed. But, every time I updated a password as recommended by watchtower, it did not ask to, nor did it update the 1PW login. I had to dig out the password and copy and paste into the login, which was a tedious process. However, when I updated the password on the discussion site moments ago, it DID ask me, so perhaps this was addressed. If not I will post again. GREAT job keeping up with the bugs and adding new features!

  • MeganMegan

    Team Member

    Hi @WDC,

    I'm sorry that updating passwords has been a bit complicated for you! Please check your options in the Password Generator in the Mini. If you click on the arrow next to the 'Fill' button, you'll see an option to simply copy. There is also an option to 'Copy to Clipboard Before Filling'. This option is checked by default, and if it is, then every time you use Fill to enter a generated password onto a website, this new password will also be saved to your clipboard. This is handy for those situations where 1Password does not ask to update your password: you can simply edit the entry and paste the new password in.

    Of course, we will do our best to help 1Password better recognize those 'change password' pages so that you have to do this workaround as little as possible.

    Thanks so much for your kind words - we're here if you have any further questions or concerns! :)

  • Megan, Hi! All was well until this morning, when the password was not saved to the clipboard nor did it show up in Passwords Generated... I have a separate post on this one done just now (did not see the notification)... I do have save to clipboard checked and also save in the browser preferences. 1PW v 4.4.1 (441008)

  • MeganMegan

    Team Member

    Hi @WDC,

    I'm sorry to hear that you're still having issues with this. Do you remember which site this occurred on? Are you seeing this problem with multiple sites, or is there a particular URL that 1Password is getting tripped up on? If there are particular URLs, please send them our way so we can improve on 1Password's behaviour here.

This discussion has been closed.