Latest 1Password release broken :(

What have you done!!!
I got a prompt to upload to the latest version - I downloaded and installed it and now every time I attempt to run 1Password Mac it immediately crashes. The OSC crash log says "check with the developer to make sure 1Password5 runs with this version of OS X" - I'm using Yosemite (as I was with the previous point release of 1Password 5.
HELP! All my passwords are in 1Password and it won't run!


  • thightowerthightower T-Dog Agile's Mascot
    edited January 2015


    1. Remove the 1Password application by dragging it to the trash.
    • Do not use an app cleaner as they can also remove your Data (passwords) and we do not want that.
    1. Reboot
    2. Download a new copy from the store you purchased from (web or MAS) The 2 versions are not interchangeable. So please download from where you have a license.
  • My 1password also broke after today's update. I got this message in the "Problem Report"

    Process: 1Password 5 [1152]
    Path: /Applications/1Password 5
    Identifier: com.agilebits.onepassword4
    Version: ???
    Code Type: X86-64 (Native)
    Parent Process: ??? [1]
    Responsible: 1Password 5 [1152]
    User ID: 501

    Date/Time: 2015-01-31 15:46:27.636 +0100
    OS Version: Mac OS X 10.10.1 (14B25)
    Report Version: 11
    Anonymous UUID: C30D1E7F-515B-9352-AFF8-717B88F1D2F4

    Sleep/Wake UUID: 0DA0B070-6C31-4B2C-9FFA-336398EB293C

    Time Awake Since Boot: 12000 seconds
    Time Since Wake: 260 seconds

    Crashed Thread: 0

    Exception Type: EXC_BREAKPOINT (SIGTRAP)
    Exception Codes: 0x0000000000000002, 0x0000000000000000

    Application Specific Information:
    dyld: launch, loading dependent libraries

    Dyld Error Message:
    Library not loaded: @loader_path/Frameworks/CrashReporter.framework/Versions/A/CrashReporter
    Referenced from: /Applications/1Password
    Reason: image not found

  • Your post apparently crossed the one above. There's good advice in post #2.

  • thightowerthightower T-Dog Agile's Mascot


    Please follow the advise I posted above your post about re downloading the app.

  • edited January 2015

    @hawkmoth @thightower thanks!!! Super fast response that worked like a charm!! :D:D

    Btw. I forgot to restart the computer, but it seemed to work just by a reinstall.

  • thightowerthightower T-Dog Agile's Mascot


    I would go ahead and restart as sometimes Yosemite gets confused and will be trying to run portions from the app thats in the trash. Due to the nature of 1Password now I would suggest a restart anytime you have to manually remove one version for another.

  • Thank you @thightower your instructions worked perfectly and I have 1Password5 back in business - thank goodness!

  • thightowerthightower T-Dog Agile's Mascot


    Thats great news and I am glad to have helped

  • MikeTMikeT Agile Samurai

    Team Member

    Hi guys,

    @hedgert and @reklam1234,

    We're trying to investigate the crasher here. Can you guys help us with this by emailing us your diagnostic report to [email protected] with a link to this thread. Please put ATTN: MikeT in the email subject, so I can find it.


This discussion has been closed.