auto-lock disabled, but FF extension locks

split from "Keep unlocked on Windows?" (beta forum)
DBrown wrote:

[*]This is still less secure than the default behavior. You may want to consider tightening up your Auto-Lock settings on the Security tab of 1Password preferences.

I have auto lock disabled, and the FF extension still locks itself after some time (even if browser is kept running).

Is this expected behavior?

Edit: This was on beta 187. I didn't notice 188 was out until now. Wanted to mention it in case 188 isn't just a release build of 187.

Edit2: Same behavior in 188. Guess I should post this in the other forum then.

Comments

  • DBrownDBrown 1Password Alumni 1Password Alumni
    Frode, welcome to the forum!

    Do you have all three of the "auto-lock" options disabled on the Security tab of 1Password preferences?

    Also, what's the setting of the new "leave extensions unlocked" option on the Browsers tab?
  • edited April 2011
    DBrown wrote:

    Frode, welcome to the forum!

    Thank you! :)


    Do you have all three of the "auto-lock" options disabled on the Security tab of 1Password preferences?

    I do.


    Also, what's the setting of the new "leave extensions unlocked" option on the Browsers tab?

    Checked.

    And it does partially work. If I unlock it's still unlocked even if I close and restart browser. It just still locks after some time.

    For example, earlier I was in FF surfing. Every now and then, I popped up the extension and verified it was still unlocked. I closed and reopened FF, verified it was still unlocked. I then minimized FF and played a game for a good while. I exit the game and pick FF back up and the extension has now locked.

    I just tried enabling auto-lock and setting it to the max it allows (180 minutes). Let's see how that works out.
  • I was just away from about when I posted the last update and until now. Less than half an hour. It has now locked.

    While I haven't timed it, it almost seems like a hard coded 20 minute lock timer.
  • DBrownDBrown 1Password Alumni 1Password Alumni
    edited April 2011
    It does, indeed, Frode. I was running the same test :) and have just seen the same thing with build 188 in FF 3 and 4, so I'll mention it to the developer.

    Thanks again!
  • Frode wrote:

    I have auto lock disabled, and the FF extension still locks itself after some time (even if browser is kept running).


    This has been fixed in 1.0.5.189, but you'll have to go into Preferences and re-configure your auto-lock settings (my advice is to turn auto-lock back on, then click OK, then turn auto-lock off, then click OK).
  • Noted. Just waiting for the release then, thanks. :)
  • Frode wrote:

    Just waiting for the release then


    It is available now.
  • AWESOME! I was just coming here to post this same problem. I'm very much looking forward to this fix. Thanks Agile; you're really living up to your name!
  • DBrownDBrown 1Password Alumni 1Password Alumni
    Thanks, pycet—we do try. :)

    I hope you and Frode will let us know build 189 works for you.
  • Looking good as far as I can tell. Have had the computer up for a few hours, most of the time not browsing, and still hasn't locked on me.
  • DBrownDBrown 1Password Alumni 1Password Alumni
    That's good news, Frode. Thanks for the follow-up!
This discussion has been closed.