1Password doesn't enter password properly on vistaprint.com

I updated my password on vistaprint.com to a longer password. When 1Password (desktop Mac) tries to log in to the website, the login fails.

I can see that the password (dots) appears to be shorter than the new password. If I go up to the browser or mini 1P icon and copy the new password and enter it on vistaprint, it will let me log in. 1P isn't entering the password correctly even though it has the correct password.

I tried this on an iPad and an iPhone and 1P will not fill in either the vistaprint username or password on 1P's internal browser.

1Password Version: 6.6.1
Extension Version: 4.6.3
OS Version: 10.11.6
Sync Type: via Dropbox
Referrer: forum-search:vistaprint


  • edited February 2017

    I am having the same problem with many websites (including this support forum, actually).

    1Password Version: 4.4.3
    Extension Version: ???
    OS Version: 10.9.5
    Sync Type: via Dropbox

  • Hi @Kino (and @conorchinitz),

    Can you try visiting Vistaprint's login page please and save a new Login item using the steps outlined on our page How to save a Login manually in your browser. I suspect this will correct the issue. In my tests I found 1Password didn't correctly recognise the change password form although I think the next beta should help with that. When I updated the Login item I had with the new password it correctly filled and logged me in so I'm thinking you should find a new item works. Please do let us know if this isn't the case.

  • Yup, that fixed it for me. Thanks!

    I can tell that Vistaprint is a little different than most websites. For one thing, it doesn't take the "Submit when enabled" from 1P.

  • Greetings @Kino,

    Well at least we solved part of the issue although your response indicates the 1Password's behaviour you see still differs from mine. I have Submit when enabled set too and it works okay for me. What browser do you use? I've been testing in Vivaldi but maybe a different browser yields different results.

  • I'm on a Mac w/ the latest Firefox version. It was wonky on Safari as well.

  • matthew_agmatthew_ag 1Password Alumni

    Hi @Kino,

    That's strange, I just signed up for a Vista Print account myself to test this out using the following setup and I was able to get 1Password to fill & submit on both Firefox and Safari.

    • 1Password for Mac 6.6.1 (AgileBits Store)
    • Safari 10.0.3 (12602.4.8) with 1Password for Safari 4.6.3
    • Firefox 51.0.1 (64-bit) with 1Password for Firefox 4.6.3

    Since you've already checked the "Submit when enabled" field, could you also double check whether the following setting is enabled in your 1Password > Preferences > Browsers please?

    Many thanks for letting us know. Hopefully we can get the Auto-Submit to work on your Mac too,

    Best regards,

  • Matthew, as I said above, following the suggestion from littlebobbytables of saving a new login for the website fixed the problem.

    Yes, the Filling and Signing In preference item had been selected.

  • matthew_agmatthew_ag 1Password Alumni

    Hey @Kino,

    Sorry for any misinterpretation, I'm glad to hear littlebobbytables' suggestion helped with the filling. :chuffed: If things are working fine for you please ignore the rest of my post. It sounded like you had a bit of trouble with Auto-submission of the Vistaprint Login item so thought I'd see if I could help with it.

    Would I be right in saying your Vistaprint Login isn't auto-submitting for you?

    If not, I thought it might be useful to list out the steps I took to create my Login item to see how it compared with yours. Here's mine:

    1. I opened the following URL: https://secure.vistaprint.com/vp/ns/sign_in.aspx
    2. Entered my username & password into the fields of the web form.
    3. Clicked the 1Password extension button > Settings Icon > "Save new Login"
    4. 1Password prompted me to save the Login.
    5. I reloaded the Vistaprint sign in web page so the fields were blank again.
    6. I used 1Password's Cmd \ keyboard shortcut to fill in the fields. After filling, 1Password submit the form also.

    There is a difference in how the auto-submit process works between the Mac App Store version the AgileBits WebStore version of 1Password but based on your comments in other discussions it appears you have the WebStore version which should be more robust at auto-submitting web forms.

    In any case, please let me know how the above compared with what you see.

    Best regards,

  • <Would I be right in saying your Vistaprint Login isn't auto-submitting for you?>

    Nope, it's working fine with the newly saved login.

    I started using 1P back in 2007 and got it from a MacWorld giveaway. I updated to versions 3 & 4 by payment directly to Agile Web/AgilBits.


  • matthew_agmatthew_ag 1Password Alumni

    Ah thanks for clearing that up @Kino. Just some confusion on my end. Glad things are working for you and nice to hear from a long time supporter of 1Password. :chuffed:

    Best regards,

This discussion has been closed.