Use Native Messaging Protocol is not staying enabled upon reboots

This discussion was created from comments split from: 1Password 4, Browserextension not longer working.

Comments

  • I understand that "Use Native Messaging protocol" in the Help/Advanced menu of 1Password 4 for windows shall be turned on, as without this the browser extension switches to a read-only version.
    However, after each restart of my computer this setting is lost and I have to set it again and again manually. Is there a solution to keep the native messaging protocol constantly in the "on" position?
    I use 1Password also on OSX connected the vault via Dropbox.
    Thanks, Zoltan

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @zokovari,

    Thanks for reporting this.

    Do you have 1Password 6 or 7 installed? Please open Control Panel > Uninstall a program and make sure that only 1Password 4 is installed.

    If you have newer version of 1Password installed, it will force native messaging to be enabled for it. I suspect that's also why you're seeing the read-only message, as 1Password 7 uses that wording via extension.

  • Thank you, Mike. That helped.

  • MikeTMikeT Agile Samurai

    Team Member

    You're welcome! If there's anything else we can do to help, let us know.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file