MrC's Convert to 1Password Utility (mrc-converter-suite)



  • MrCMrC Community Moderator

    @markaceto ,

    For the macOSConvertHelper and the Can't get Window 1 of ... error you see, is Terminal opening at all? I'm not able to reproduce your issue.

  • MrCMrC Community Moderator
    edited February 3


    You're very welcome.

    I'm so sorry, I didn't see your post until just now. For some reason, I didn't get the notification (I did get one for the person who posted after you).

    I don't really support El Capitan anymore with the converter suite, but let's see. I think the issue for you may be easy...

    It appears you command shell is not in the correct folder (aka directory). I see this in the error message in your post:


    but below that I see this:


    The "username" part is not right, and doesn't make sense for the username of "dn". I don't even know how you have some folder named "/Users/username" on your system, unless this is some weird coincidence where you accidentally created a user profile on your Mac with that name!

    If you placed the mrc-converter-suite folder on your Desktop, then in the command shell, run the command:

    cd $HOME/Desktop/mrc-converter-suite

    If you get no errors, you can run the converter command again. If you get an error, move that folder to your Desktop and try again.

    Alternatively, you can type cd (with the trailing space) and then via Finder drag the mrc-converter-suite folder (where ever it is) into your Terminal window. macOS will put the path into Terminal on the command line for you. The just hit Enter and issue the convert command.

  • markacetomarkaceto
    edited February 2

    @MrC ,


    Each time I ran the script, it would open the Terminal app but not a Terminal window, so after I read your last comment, I clicked on Terminal to open the window, and everything worked as expected. I tested it a few times each way, and was able to reproduce those results accordingly.

    For the multiple web-host names, I created a smart folder: Notes / Contain / Extra URLs

    There are 56 items in that folder, which looks accurate. I'll begin batch changing these manually unless you have a better suggestion how to manage that procedure.

  • MrCMrC Community Moderator
    edited February 2

    @markaceto ,

    Great. The applescript should have opened the window for you automatically, so I'm at a loss as to why it failed for you.

    If you don't mind waiting, I'll update the converter suite to add the special row to the CSV, and the csv converter will add the extra URLs. To speed up my coding for your immediate needs, do you want separate Login items, or add the grouped URLs to the Login entry so that you can click on any of them?

  • @mrc ,

    If I understand correctly, I would like separate Login items please.

    Thank you!

  • @mrc ,

    Ah, I see the screenshot you just added. Honestly, whatever's easiest on your end. Both options are a huge help. Thanks again!

  • MrCMrC Community Moderator
    edited February 3

    Working on it now, @markaceto . I may support 3 different methods, and will decide on the default later one (it will probably be to add the URLs as I show above in the screenshot), and optional behavior will be to store them in the Notes area as I do now, or as you're asking for as separate items. I'll assume you want separate items, unless you reply otherwise, and I'll implement that first! :-)

  • OK, took me a sec (new user) but I get it now. The way you show them in the screenshot makes the most sense :)

  • MrCMrC Community Moderator
    edited February 3

    @markaceto ,

    I've posted an update to the converter suite. The changes:

    2019-02-02 -----------------------------------------------------------------------------------------

    • New [csv]
      Login tables now support a column "Additional URLs", the value of which should be a semicolon- or
      newline-separated list of URLs. These will be added as supplementary URLs in the Login item's
      website list (so you can click on them and have them open/fill).

    • Change [GetSafari12Passwords]
      Secondary URLs are no longer placed into the Notes area; instead, they will be placed into a new
      column "Additional URLs", which is supported by the csv converter (feature is mentioned above).

    I decided to ditch placing extra URLs into Notes completely, even as an option. It just makes more sense the way it is being done now, thanks to your good feedback.

  • @mrc ,

    Still only getting the Extra URLs in notes:

    Do I need to upgrade to 1P v7 for this to work?

  • MrCMrC Community Moderator

    @markaceto ,

    My build process has become more manual than I'd like. I forgot to export from my applescript editor/debugger program the GetSafari12Passwords script as an applescript (so you go the same old version).

    I've updated the package, and just tested the download.

  • @mrc ,

    Mission accomplished. Thank you, sir!

  • @MrC I should have clarified ‘username’ was a manual replacement for the real username to post on the forum. Apparently I forgot to change it in all the paths I copied.

    So I did put the mrc-converter folder it in the right place ~/Desktop and did try with the cd command before posting the issue here. I understand you wouldn’t want to keep supporting El Capitan any longer. I’ve exported chrome password into a csv and then used your csv converter on a newer system. It imported all as Passwords in 1PW which I converted to Logins one by one. Thanks for the prompt reply. I’m guessing an older version may have worked fine but I didn’t know where to find that.

    Thanks again very much!!

  • MrCMrC Community Moderator
    edited February 3

    @Nonylus ,

    Ah, OK, that's clear now. Sorry about the misunderstanding on my part.

    I don't think this is a general El Captan issue, since I tried and tested the suite on that version of macOS just before I replied to you. It worked fine. And I've done converter work on El Capitan for years now. Is it possible that your El Capitan is not up to date? The Perl version that would be in use should be 5.18 - this can be verified by typing:

     perl --version

    on the command line. I tested both with version 5.18 (the latest installment in El Captan) and the older 5.16 (the version originally shipped with El Capitan). Both worked.

    The error you were getting indicates that a code module used by the chrome converter (PBKDF2/ couldn't be found. But it lives in the lib folder within the converter suite, and will look there. The only reason I can think of at the moment, for this failing, is that either something in the past has modified your Perl environment, or the latest macOS updates have not been applied (and some Perl module has a known bug), or only part of the mrc-coverter-suite folder contents was moved. Some users have done the latter, essentially breaking apart the package, placing, say the program on the Desktop, leaving other stuff behind. I'm thinking your El Captan system's Perl environment is the culprit here.

    It sounds like you got your data imported at any rate, so I'm really happy to hear that. Let me know if there's anything else I can help with.

    Enjoy 1Password!

    Note: I edited your post and mine, to obfuscate the username.

  • MrCMrC Community Moderator

    @markaceto ,

    Excellent, and thanks for the assist.

    Enjoy 1Password.

  • Using the get Safari 12 script and it seems to run through all my passwords but when it comes time to create the file I got the "There was an error writing the data!" is there an easy way to fix this? What am i doing wrong? @MrC

  • MrCMrC Community Moderator

    @eddiesalem ,

    This is the first time anyone has reported that issue.

    Which macOS version is this?

    At the bottom of Script Editor, what is the error message?

  • maybe i did something incorrectly...

    the third line reads the below. Is this correct? If yes, i will rerun the script and give you the exact message

    set csv_filepath to "users/eddiesalem/desktop" & "pm_export.csv"

    Thank you for taking the time to answer me

  • MrCMrC Community Moderator

    @eddiesalem ,

    No, did you change that line in the code? it should read:

    set csv_filepath to (path to desktop as text) & "pm_export.csv"

    That line constructs the path for you - you don't need to change anything in the script.

  • Switched it and now it's all good thank you!

  • MrCMrC Community Moderator


    Excellent. I started to getting worried!

    Was there something in the documentation that give the impression you should change the script? If so, I'll look at correcting it. No need to reply if not.

    Enjoy 1password.

  • @MrC

    Just FYI:
    Running the latest 10.11.6
    Both 5.16 and 5.18 perl versions are installed, I did try to use both /usr/bin/perl5.18 and /usr/bin/perl5.16
    I did check was in the lib>File folder
    Thank you for editing our posts :)

    I didn't think I had tempered with the mrc-converter-suite folder but double checked and realized permissions on the folder were fine but not on enclosed files.

    I re-downloaded the suite, moved it to the Desktop and replaced the previous version.
    Everything worked perfectly from there, so I'm 99% sure it was a permission issue, basic user error I'm sure. But your suggestions helped finding out so again thanks a lot !

    It imported a few things Chrome CSV export didn't (saved Credit cards for example)

    MrC you are a jewel in the community, it's great to be able to access amazing people through these forums!


  • MrCMrC Community Moderator

    @Nonylus ,

    Thanks so much for the status update, and your kind words. I really appreciate it, and its great to hear that your Chrome data transferred nicely.

    Enjoy 1Password!

  • Hi,

    I just attempted to use the converter to migrate from mSecure 5 (latest, Version 5.6.2 (160)) to 1password, without success.

    I ran everything according to the description, but had to specify --sepchar ";" as those were the separators in my .csv. After I did this, only a single entry was migrated, and if I check the 1pif file with a text editor I can see there is only one entry there.

    Any idea what I can do to fix this?

    Thanks a lot, your help is much appreciated!

  • MrCMrC Community Moderator

    Hi @spaggi ,

    A couple questions:
    1. Which platform?
    2. Which language?

  • Tried on macOS (I can also try on Windows if that could be the issue) and Language -> German

  • MrCMrC Community Moderator
    edited February 11

    Sorry for the delay @spaggi, I had an appoinment to attend.

    A few more questions / comments, sorry.

    1. I'm unsure why you would have semicolon as the separator for the German language. When I set my Mac to German, and set the keyboard to German, I still get commas as the separators. Can you verify that you do indeed have semicolon's ? See my sample below.
    2. Please look at one if your Logins entries in the CSV. Count the number of semicolon's (or commas) you see in a single entry, and let me know how many you count. It appears mSecure has yet again changed their CSV output (I'm seeing an empty cell - an extra comma - being output for all records). This will break the converter, since it uses the cell count to verify the mSecure category.
    3. Please note - I have not made selecting the language an option yet in the msecure5 converter, because language files were not available in mSecure5. That's OK, but I'll have to explain to you how to customize the converter a bit to match more categories. We'll do this after we resolve the (1) and (2) above.

  • Hi MrC,

    I have no idea why, but now that I've performed another export, the separator are commas. Sorry, I must have made something wrong the first time.

    I was now able to import the csv with your converter, and also import into 1password.

    However now all my logins from msecure are secure notes which have no qualified fields.

    Am I doing something wrong again?

    Thanks a lot for your help, it's much appreciated!

  • MrCMrC Community Moderator
    edited March 29

    @spaggi ,

    Ok, that’s good to hear... we’re making progress.

    How many commas do you see in a single Logins entry in the CSV?

    Try setting your Mac’s language to English, reboot, and then export from mSecure. Retry the conversion against the English exported file.

  • @MrC Aaaaaaand voilá, I'm fully migrated after switching to English!

    Thanks a lot mate! Case closed!

This discussion has been closed.