1Password can't run in Samsung DeX. Try running in tablet mode

2»

Comments

  • periperi

    Team Member

    Hi @siebica. We recently released an update that should help with using 1Password in DeX mode. Are you using the latest version of 1Password and still having trouble with this?

  • I also had to turn on developer mode before 1Password would open on my Galaxy Tab S6.

  • Hi, I am using tab s6 and not able to run 1password in Dex mode. Tried everything what people had described earlier.

  • periperi

    Team Member

    Thanks for the heads up, @abackstrom. I'm glad you were able to get it working with developer options.

    @Davia Can you let me know what version of Android and 1Password you're using?

  • @peri I am using Android 9, 1password 7.3

  • kurtdkurtd Junior Member
    edited September 18

    I have the same issue as shown in the 1st post screenshot. "1Password can't run in Samsung DeX. Try running in phone mode." This is on the Galaxy Note 10 Plus via USB-C to Windows 10.

  • periperi

    Team Member
    edited September 19

    @kurtd Thanks for reaching out. Were you able to try the workaround listed here?

    @Davia Are you seeing "1Password can't run in Samsung DeX. Try running in tablet mode" or another error?

  • @peri , Yes , I see "1Password can't run in Samsung DeX. Try running in tablet mode" message

  • periperi

    Team Member

    I see, thanks @Davia. When you mentioned that you tried the steps others have mentioned, does that include these steps?

    The way I got it working was to turn on DeX developer mode: Settings -> Samsung DeX -> About Samsung DeX. Then click on the Samsung DeX at the top five times. You'll be asked if you want to turn on developer mode. Obviously yes! Now go back to your phone settings and scroll to the bottom. You'll see Developer options. Click that and scroll to the bottom. Choose Force activities to be resizable.

  • @peri , Yes, it was already enabled. I turned it on by default before that problem with 1password app. comes up Tried on and off, install beta and public versions. Also, different things what people have described . nothing worked. @abackstrom mentioned that she just turned the developer mode on and it start working. Not sure what is wrong with my tab s6. I have start to save passwords into browser password manage to make working on DEX mode less painful.

  • periperi

    Team Member

    Thanks for confirming this @Davia. It's curious, as these steps should be working. I'll forward your feedback on this to our development team. ref: android-376

  • Wanted to add to this thread, just purchased a Galaxy Tab S6 and get the same error as previously mentioned when running in Dex mode. I have tried the enable debug option but after turning it on there is no option in settings to Force activities to be resizable.

    Is there any word on 1Passowrd working correctly in Dex mode without having to fiddle around in developer mode?

  • To update this, the Force activities to be resizable option is now located in the Dex Labs menu not at the root of developer (or at elast it is on my device).

  • periperi

    Team Member

    Hey @Geoff_2019. Are you using DeX mode while connected to an external monitor? If not, are you able to try connecting to an external monitor and let us know if that helps?

  • I dont tend to connect my tabelt to an external monitor as that defeats the point of the tablet? I can try casting it to my Chromecast but i'm not sure if thats relevant to the problem.

  • brentybrenty

    Team Member

    According to their marketing, that seems to be the purpose of Dex: connecting the device to external displays. You don't have to try it if you don't want to. We're just trying to get a better understanding of the problem. :)

  • kurtdkurtd Junior Member

    I connect my Note 10+ to a usb c port on Windows and then use the DEX app on my Windows 10 PC to access the phone via Dex mode so I don't connect any external display to my phone directly either although I know you can. Anyway it would be nice if there would be a fix for this issue soon. In the mean time, I just copy the passwords on the phone screen and then paste in dex mode.

  • brentybrenty

    Team Member

    That's really interesting. Thanks for sharing your use case! hopefully we'll be able to figure out what Dex wants and get it working better. :)

  • periperi

    Team Member

    We've got a bit of info regarding this issue, and I'd appreciate any feedback. For those of you still having trouble with this, could you please. launch 1Password,. tap Settings > Advanced, and enable screenshots? Does that help?

  • kurtdkurtd Junior Member

    Settings > Advanced, and enable screenshots.... That did not help for me, same issue.

  • periperi

    Team Member

    Thanks for checking, @kurtd. Had you previously enabled developer options to try the workaround here, and if so, was this still enabled when you tried enabling screenshots?

  • kurtdkurtd Junior Member

    I have not tried developer mode as it doesn't seem like the most secure thing to do.

  • kurtdkurtd Junior Member

    I went ahead and turned on developer mode and it would then open but said can't view protected content on the PC. I then enabled the screenshot feature in 1password and now it works in dex mode so I guess both needed to be enabled. Just did this for a test, will revert back now so I hope this can get resolved without needing these options enabled.

  • periperi

    Team Member

    Thanks so much for testing that. I was hoping that enabling screenshots would work without developer options needing to be enabled, and I'm sorry to hear that's not the case. But I'll report this to our team.

  • I'm on a Tab S6 LTE - no external monitor connected - most recent LastPass version (7.3.2) and DeX says it's up to date.
    Having gone through this thread, the following:
    Turning "force apps to resize" on in DeX Labs yielded the same error others are getting.
    Looking at my 1Password settings, "appear on top/allow draw over other apps" was disabled so I enabled that permission. Same error.
    Enabled Developer mode in DeX and 1Password works (with Screenshots disabled).
    Disabling "force apps to resize" in DeX Labs and restarting DeX still works.
    Disabling "appear on top" does not seem to affect 1Password starting.

    Disabling Developer mode and restarting DeX yields the "use in tablet mode error" but re-enabling Developer mode immediately fixes the issue.

  • periperi

    Team Member

    Thanks for confirming this behavior, @Jenouflex!

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file