Dropbox Sync Not Working

I realize there has been a few other forum posts regarding dropbox sync not working and the solution to disable dropbox syncing in preferences and then reenable. This works, however the same problem returns once my mac is restarted. When I add or change an item, the dropbox icon shows no activity, but the sync preference pane indicates a sync is occurring (ie "Last synced: 1 min ago").

Any ideas?

«13

Comments

  • I'm also having problem with the Dropbox sync. Disabling/activating work "kind of" because sometimes it doesn't remove items that I've deleted on another device.

  • MikeTMikeT Agile Samurai

    Team Member

    Hi guys,

    That's not really the solution we recommend, disabling/re-enabling shouldn't be used to fix anything.

    Can you tell me more about the 1Password setup you have:

    1. Are you syncing between Macs only or are there other platform devices involved such as iOS device and Windows computer?
    2. After making some changes, check 1PasswordAnywhere on Dropbox, does the changes show up there?
  • Hi MikeT,

    1. Trying to sync to Dropbox so iPhone, iPad, and Windows laptop sync.
    2. No. Nothing is being updated in the Dropbox folder after the initial setup once 1Password is shutdown/computer rebooted.

    Thanks,
    Josh

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @applejosh,

    Just to be clear, 1PasswordAnywhere is not in the Dropbox folder but on Dropbox.com, can you check the changes there.

    Note that 1Password.agilekeychain itself will not have an updated timestamp even if you make changes, the changes are made directly within the data file.

  • Correct. Nothing is changed on the dropbox.com site. I ran 1PasswordAnywhere from there (had to, it doesn't work locally). Dropbox app log file shows no uploads or file changes happening. 1Password is not syncing changes (even though in Preferences, it shows it had).

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @applejosh,

    Are you using multiple vaults or just one vault? Does the Sync Preferences in 1Password match up to the same data file in Dropbox?

    If single vault and yes to the match, try this:

    1. Open the main 1Password app, unlock, go to the File Menu > Backup to create a backup
    2. Go to the 1Password Menu > Preferences > Sync, disable Dropbox and tell it to delete the data file in the Dropbox folder
    3. Once it does that, go to the Dropbox folder, and confirm the data file has been deleted. Wait for Dropbox to finish syncing.
    4. Now, re-enable the sync with Dropbox in 1Password 4 and see if that'll fix the problem.
  • pgseyepgseye Junior Member

    Hi MikeT,
    Dropbox syncing has been hit and miss (more miss) for me as well. I just did what you suggested earlier and unlike applejosh, the changes I make on my laptop are seen in 1PasswordAnywhere on Dropbox.com. But the changes aren't being pushed to my phone or mac mini for some reason. To get around this yesterday, I disabled syncing on all my devices, then restarted Dropbox sync one by one and for a short time, everything seemed to update. But today I'm having the same issue again. Any ideas?
    Thanks,
    Paul

  • Single vault. Sync preferences match up to the same data file in Dropbox.

    1. OK.
    2. OK
    3. It does NOT delete the Dropbox data file. (This is the second time I've set up 1P on Mac to do Dropbox sync, and I've verified both times that it was pointing to this file -> ~/Dropbox/1Password.agilekeychain. I deleted it manually and verified the file was gone from the dropbox.com website.)
    4. Did this. It creates the new file in ~/Dropbox/1Password/1Password.agilekeychain instead of the root of the Dropbox folder.

    I've rebooted, and so far, it is still syncing, so that's a much better situation. I erased my data in 1Password for iOS on iPhone and setup sync again. It appears to work. However, I've noticed that the sync with Dropbox the iPhone will frequently hang. I have to end task it and/or reboot the phone for it to actually sync. So at least I have a working solution even after I do what caused issues before (rebooting). But the syncing on the iPhone (haven't tested it on my iPad or Windows box yet) is a concern. Thank you for your assistance on this matter.

  • Installed version 4 on the mac. Made changes to one or more entries. Says sync to Dropbox was "seconds ago." Launch 4.2.7 on my iPhone (iOS 7) and force sync. Changes do not show up.

  • Just ran a test. Opened my keychain folder on Dropbox with 1Password 3 on the Mac. The changes I made to my keychain in 1Password 4 (Mac) are not there. Does this imply that 1Password 4 (Mac) is not saving changes to Dropbox?

  • @MikeT - the solution you proposed is exactly what I was referring to. In my case after disabling dropbox sync (and choosing that data file in dropbox be deleted) and then re-enabling (which re-creates the data file in dropbox) seems to have solved the issue. Interestingly though, as was pointed out by another poster, my data file in dropbox was originally in the root folder. When the data file was re-created it is now in the folder "1Password" and no longer in the root folder.

    I should also mention that although I have been using 1Password for years and think it's a great product, version 4 seems to be half-baked. Proper testing would have ensured these issues would have been dealt with. In addition, the omission of such functionality as printing really isn't acceptable. I would rather have waited another 6 months for a properly tested program. Why the rush? Data integrity and user experience should be paramount.

  • I can confirm the same issues with trying to use Dropbox sync after upgrading from v3 to v4. The only way I could get it to work was to turn off all syncing with Dropbox and then manually remove all 1Password files from the Dropbox folder. The other issue I am having is getting the Dropbox sync to work with the iPhone app. It kept trying to sync with iCloud and was merging old data from the iPhone. So I had to delete everything from iCloud, reset the data on the phone, and restore from a backup to fix things (kind of a messy upgrade process). And during the sync process the iPhone app kept failing with rate limiting errors (something about the oath token being over the limit).

  • I too am experiencing problems with the Dropbox syncing and 1Password 4. The Dropbox files are indeed updated and synced, but the 1Passwor application does not seem to use the updated data?

    I tried changing a password on one computer, which propagated fine through Dropbox to the other computer. 1Password 4 still show the old password though.

    Is there any kind of caching made by 1Password, which should be flushed?

    I have also tried to disable 1Password/Dropbox sync, ensure that 1Password files are completely deleted from Dropbox (including the hidden setting file in the Dropbox root folder, and then re-initate the sync in 1Password. No luck.

    I have chosen to place my 1Password-files in a subfolder on Dropbox. But, that should not make a difference, right? (And yes, both computers' 1Password Dropbox preferences point to that folder).

    Please, advise.

  • Hi all, I have the same problem as you guys. Disable and reenable sync solves the problem temporarily. The problem is back after reboot

  • LocalboyLocalboy Junior Member

    I noticed that 1Passwords 4 changes made on my iMac are not being reflected in my Macbook Air and vice versa using Dropbox sync. It appears this may be a fairly widespread problem without a great solution so far. Would switching to iCloud sync be a workaround? And how could I set up so just the 1Password data from the iMac is used and not the data on the Airbook which is missing a bunch of changes?

    Not a happy camper. :-S

  • Sal ConigliaroSal Conigliaro Junior Member

    I can confirm that my 1Password (Version 4.0 (400200)) changes also are not being sync'd to Dropbox (even though the app says it is).
    I have a single vault.

    Disabling and re-enabling Dropbox syncing temporarily fixes the issue.

  • The fix of disabling and re-enabling dropbox permanently fixed the situation in my case but you have to remember to choose the "delete data from dropbox" option when disabling dropbox sync. My understanding is that that database file in dropbox is simply a "sync store". The 1Password main database syncs to the sync store (database) in dropbox. It seems that there is a bug in importing the database from dropbox (version 3 to version 4) in that 1Password 4 can not sync back to the original dropbox database. By disabling dropbox sync and deleting data from dropbox, and then re-enabling dropbox sync, 1Password will re-create the database file in dropbox and syncing should be permanently fixed.

    Likewise, you should go into any other device (iPhone etc) and disable syncing and choose the option to delete 1password data on the device. Then re-enable dropbox syncing once you've completed the above on your main mac. This will re-create the local database on the device as well.

  • LocalboyLocalboy Junior Member

    Cyclist - Thanks for the tip. I switched my main mac over to iCloud sync and deleted the data on dropbox. Then I changed the Airbook sync to iCloud and also deleted the data. They seem to sync fine now in iCloud although I did have some conflicts in the data that I had to correct after the merge. Now I'll have add my iPad into iCloud sync which I think I'm going to do by deleting 1Password from it and reinstalling.

  • This has got to be the strangest update I've seen for 1PW! I managed to follow the instructions on making a Manual backup only because I always make a zip backup of any app before updating it. Otherwise, I would not have had a copy of 1PW 3 to use! (OK, I could have Restored it from Time Machine...)
    I also managed to get DropBox Syncing restarted using the instructions from MikeT in post #7. But I haven't done a Restart yet, so who knows if it will stick.
    Just got through with my iPhone resync. First, it tells me the DropBox file doesn't agree with what's on the iPhone, "Tap to Merge." 1PW on yhe iPhone crashed. :rolleyes: Force Quit the iOS app and restarted it. Turned DropBox sync OFF then ON. Syncing started and ran... and ran... and ran... I was about to Force Quit the app again, thinking it was in an endless loop! The progress bar just kept completing and starting over again and again. All the while I'm getting 'beeping' from Notification Center on my iMac reporting file changes in DropBox files. After at least 10 minutes (I had to tap the iPhone at least 5 times to keep it awake with my 2 minute sleep setting), things calmed down and it appears the tow apps agree on what's on DropBox, 834 items.
    I know this is a complicated app and it has always been stable and fantastically bug free, but I hope to never see another update like this! ;-) Fingers crossed for a restart! 8-)

  • I'm having the same issue as everyone here. Have 1P4 for OS X and iOS. I made changes in the OS X version and using Dropbox to sync, the changes do not appear even though the app is saying that it synced just a moment ago. I haven't tried deleting and then reinstalling but if I'm just going to have to do this on reboot, it hardly seems worth it.

    I'm pretty disappointed.

  • drew212drew212 Junior Member
    edited October 2013

    I am also having major problems with Dropbox sync. This upgrade has been utterly infuriating to me. I was in the Beta testing program and everything was working fine (eventually), but now since switching to the paid MAS version, nothing syncs right.

    I can confirm that changes made on one machine are being synced in Dropbox in my .agilekeychain file. I can go in in the Finder using "Show Package Contents" and drill down to the "data" subfolder. If I open the most recent *.1password files using a text editor, I can see that they are the changes I made on one machine and those *.1password files propagate to other machines (I can see from the non-encrypted data elements). But they are never loaded into the 1Password instance running on other machines. Even if I reboot the machine, 1Password is frozen in time at the point before those changes were made on the other machine. Changes never sync in. None of this was a problem in the Beta.

    To answer your question about 1PasswordAnywhere, @MikeT: No, it cannot be loaded. Something about the 1Password.html file is corrupt. When I try to open it, I get the following error message:

    Problem loading 1Password data file

    A key data file could not be loaded and 1PasswordAnywhere cannot continue without it.

    Please see this help guide for troubleshooting tips.

    Syncing of my Dropbox is fully complete. When I click on the "Key Data File" hyperlink in the above error message, it opens and displays the text of a file "1Password.agilekeychain/data/default/encryptionKeys.js".'

    I have also been experiencing the Attachments Lost During Editing bug (http://discussions.agilebits.com/discussion/16405/attachments-lost-during-dropbox-sync-confirmed-will-fix-asap#latest) and am worried by reports of missing data and items (http://discussions.agilebits.com/discussion/16424/missing-items-after-updating-mas-version-to-4#latest).

    I understand that this is a complex piece of software, with a complex data file format involving encryption, with all the complexity of syncing across many platforms. I am totally losing faith in 1Password. I also saw the attentiveness during the beta phase, but I am feeling surprised (A) that the app came out of beta when it did, because it seemed premature based on what I was seeing, and (B) responses in these forums to reports of data loss from AgileBits representatives are more cavalier about the possibility of data loss than I would be comfortable with, @sjk.

    With a piece of software that is managing nearly 1800 items of password and encryption data for me, I have to have 100% confidence. I did through 1Password 3. My experience with 1Password 4 is not good. I have no confidence left in the data integrity of my password file, which is obviously absolutely unacceptable.

    Thanks to a history of transparency from AgileBits, @dteare, and @nik, I am willing to hold on and give some leeway (even with the major annoyance of having to be vigilant to ensure data is safe somewhere OTHER than 1Password too!), but my goodwill will be limited. This upgrade seems pretty bungled from my standpoint so far and I hope things turn around soon.

  • roustemroustem AgileBits Founder

    Team Member

    Is this issue only happening for Mac App Store version of 1Password? Does anyone running the non-Mac App Store have the same problem?

  • roustemroustem AgileBits Founder

    Team Member

    @drew212,

    The 1Password.html file usually cannot be loaded from the disk because the browser would prevent it from loading other files. The easiest way is to open it directly on dropbox.com website.

  • oshloeloshloel Junior Member

    On the flip side, I have the MAS version and dropbox SEEMS to be syncing fine to my iPhone & iPad (absent the Attachments issue). Guess I'd better knock on wood and/or continue with the other incantations I've been reciting...

  • roustemroustem AgileBits Founder

    Team Member

    My only guess at the moment is that because of the sandbox, the Mac App Store version might be losing the access to the Dropbox folder at some point. This would explain why "Delete data" checkbox is not working when trying to disable the sync.

    Do you see any message shown in Console right after you make the change in 1Password and the sync is triggered?

  • oshloeloshloel Junior Member

    Roustem, I'm not sure whether your query was direct to me or others since dropbox sync appears to be working with the MAS version for me. Nevertheless, here you are. I triggered a sync with a small change in an item and then searched the Console for any logged actions. I found one for 1pw4 MAS and a virtually identical one for dropbox as follows. I'm not sure these are what you are looking for, but they're the only ones I could find in the console with a relevant timestamp. Note that my dropbox icon showed a sync action when I clicked Save on the edited 1pw4 item.

    1pw4 MAS:
    10/8/13 3:29:38.123 am UserEventAgent[155]: com.apple.message.domain: com.apple.usage.app_activetime
    com.apple.message.signature: 2BUA8C4S2C.com.agilebits.onepassword-osx-helper
    com.apple.message.signature2: 2BUA8C4S2C.com.agilebits.onepassword-osx-helper ||| 4.0 (400200)
    com.apple.message.value: 63
    com.apple.message.value2: 0
    com.apple.message.value3: 0
    com.apple.message.value4: 0
    com.apple.message.value5: 0
    com.apple.message.value6: 0
    com.apple.message.value7: 0
    com.apple.message.result: NO
    com.apple.message.summarize: YES

    Dropbox:
    10/8/13 3:29:38.120 am UserEventAgent[155]: com.apple.message.domain: com.apple.usage.app_activetime
    com.apple.message.signature: Dropbox
    com.apple.message.signature2: com.getdropbox.dropbox ||| Dropbox 2.4.1 (2.4.1)
    com.apple.message.value: 63
    com.apple.message.value2: 0
    com.apple.message.value3: 0
    com.apple.message.value4: 0
    com.apple.message.value5: 0
    com.apple.message.value6: 0
    com.apple.message.value7: 0
    com.apple.message.result: NO
    com.apple.message.summarize: YES

  • jwholderjwholder Junior Member

    Downloading 1P from the Agilebits site fixes the Dropbox syncing problem (I had been using the Mac App Store version.) Once you download it (version 4.0.1) it will alert you to install another update (version 4.0.2) which you should do!

  • @jwholder,

    Does it recognize a valid license? Im not interested paying for a new license bought on the website

  • sbauersbauer Junior Member

    I have the Mac App Store version and Dropbox sync is not working. I'm not going to load the web version because I too am not interested paying for a new license bought on the website.

    When can we expect an update to the MAS version to correct the problem? I'm hanging in there as I'm a huge fan, but right now I'm very concerned. 1Password is an integral part of my workflow.

  • So is there a fix that is being worked on to address this issue for the App Store version? Is there an official work around that gets things working again? I see a few "this worked for me (kind of)". But, that makes me nervous. This is a pretty critical piece of software that I don't want to experiment around with.

This discussion has been closed.