Cannot open 1password or 1password mini

Hi, after updating to the latest beta version of el capitan today build 15B22c, 1password now fails to open. Get the error relating to connections to 1password mini and the app then closes. I have tried re-installing and rebooting but sadly same issue. Any help appreciated.


1Password Version: 5.4-beta42
Extension Version: Not Provided
OS Version: 10.10.11 (15B22c)
Sync Type: Not Provided

Comments

  • Hi @Willy_T,

    We are aware of one cause at the moment, let's see if this applies to you :smile:

    1. Ensure you only have a single copy of 1Password on your Mac, you will want it to reside in /Applications/.
    2. Use the following command in a Terminal window. The command is xattr -d -r -s com.apple.quarantine /Applications/1Password\ 5.app.

    So we had a few reports from people running the last El Capitan beta and it seemed for reasons unknown that the quarantine flag, set by when you download something, isn't being removed. I don't know if it's the case that it isn't being removed properly or if for some reason the user isn't seeing the normal prompt. Anyway, if that flag is present OS X won't allow you to run 1Password as it's trying to protect your system. The command tells OS X to remove the flag and then you should find 1Password runs.

    Let us know how you get along :smile:

  • Yep that did the trick! Thank you :-)

  • Great to hear and thank you for letting us know :smile:

    Enjoy El Capitan!

  • I just installed El Capitan today and while 1 Password 5 ran without issue, the safari extension would not download (kept seeing the agilebits "we're sorry" page). I checked the xattr of /Applications/1 Password\ 5.app and it had the quarantine still there. Ran the command and then the extension downloaded and installed fine. So while 1 Password was happy, the mini/extension bits weren't.

  • sjksjk oversoul

    Team Member

    Hi @sshumway,

    That's a different twist on the quarantine issue with 1Password and El Capitan. Glad you figured it out and thanks for bringing it to our attention! :+1:

  • Hi guys,

    I am having the same issue, but the cited command doesn't work for me oddly.

    I am using 1Password 5.3 for Mac, and I just purchased it. I don't know if it matters, but I haven't ever used the application so the error happens upon the first run. I have removed the application and recopied it. I have also restarted multiple times.

    I am running this under the latest el-cap non-beta. Any ideas or experiences why this might happen? I'm looking forward to branching out from 1P IOS to the mac and Windows versions so I hope we can figure this out.

    Thanks.

    Noel

  • JacobJacob

    Team Member

    Hey @nromey! Could you check to see which version of the app you're running? You said 5.3, but was it downloaded from the Mac App Store or the AgileBits Store? Also, could you post the exact error you're receiving when you open 1Password? That'll help us figure out what's going on. :)

  • Hello,

    I downloaded the app from the Agile Bits store. Believe the thing says 5.3.2 in the zip file.

    The error is the standard
    "password failed to connect to 1password mini" error.

    I have followed all troubleshooting steps that I have seen throughout the forums with no success. I haven't tried any betas.

    Noel

  • As an experiment and to add to my post, I downloaded the beta and performed the same command. Still no luck. I wonder if it would be different if I had used the software before installing el-capitan. No idea.

    Any ideas would be greatly appreciated.

    NER

  • I downloaded the beta and performed the same command.

    Does that mean you now have two copies of 1P on your Mac (1Password.app and 1Password 5.app)? That of itself could give rise to the error you are seeing.

    Stephen

  • JacobJacob

    Team Member
    edited October 2015

    @nromey Thanks for posting that version and error.

    As an experiment and to add to my post, I downloaded the beta and performed the same command.

    Did you add this to your Applications folder, or replace the current version of 1Password with the beta? If you simply added another version, that can cause some confusion in the app's communication with 1Password Mini. If you didn't, could you please create a Diagnostics Report from your Mac?

    Attach the Diagnostics Report to an email message addressed to [email protected].

    Please do not post your Diagnostics Report in the forums, but please do include a link to this thread in your email, along with your forum handle so that we can "connect the dots" when we see your Diagnostics Report in our inbox.

    You should receive an automated reply from our BitBot assistant with a Support ID number. Please post that number here so we can track down the report and ensure that it is dealt with quickly. :)

  • The Terminal command: "xattr -d -r -s com.apple.quarantine /Applications/1Password\ 5.app" solved the problem for me as well. Thanks.

  • JacobJacob

    Team Member

    Hey @AdrianBrancato! Glad to hear it! That's why we love our forums — lots of knowledge from lots of different folks. :)

  • Regarding the command syntax: "xattr -d -r -s com.apple.quarantine /Applications/1Password\ 5.app"
    it would seem to me that the last backslash should have been omitted?
    But, in fact, when I entered the Terminal command as listed in the original post I entered it "as is", with the backslash.
    Terminal accepted it and replied:
    Adrians-iMac:~ Adrian$ xattr -d -r -s com.apple.quarantine /Applications/1Password\ 5.app
    Adrians-iMac:~ Adrian$

  • JacobJacob

    Team Member

    @AdrianBrancato Actually, if you omitted that backslash, Terminal wouldn't have the correct path to the app. Since "1Password 5" has a space in it, you have to define that for Terminal. In file paths, this is done by using a backslash and then a space. You can learn a bit about it in this thread if you'd like. :)

  • edited October 2015

    Thank you, penderworth, for your perfect answer, above and beyond the call of duty. ;-)

    You can enclose the whole path by double-quotes ("), single-quote (') or escape the space character using a backslash (\)
    cd "/path/path/path/A Folder/file"
    cd '/path/path/path/A Folder/file'
    cd /path/path/path/A\ Folder/file

  • JacobJacob

    Team Member

    @AdrianBrancato No problem at all. We love helping folks learn fun little tricks. :) Have an awesome weekend, mate!

  • sjksjk oversoul

    Team Member

    You can enclose the whole path by double-quotes ("), single-quote (') or escape the space character using a backslash ()

    Single-quoting the full filename path is what I've suggested here:

    • Copy this single line command, then paste it into the Terminal window you just opened:

      xattr -d -r -s com.apple.quarantine '/Applications/1Password 5.app'

    • Tap the return key to run that command.

    • Open 1Password 5 app.

    Here's that command again in case the formatting above makes it tough to copy:

    xattr -d -r -s com.apple.quarantine '/Applications/1Password 5.app'

    Cheers! :)

  • I tried that, open terminal, pasted " xattr -d -r -s com.apple.quarantine '/Applications/1Password 5.app", didn't work.

    I am on OS 10.11.2, 1password 5 (downloaded today) 27Dec15.

    can someone help?

    the problem started when i updated the Mac OS today, and its frustrating on all these incompatibility issues.

    thanks in advance for looking into this.

  • sjksjk oversoul

    Team Member

    Hi @peterkq,

    Sorry you're having this trouble getting 1Password to open and connect with 1Password mini after your OS X update.

    Before doing anything else to fix this, please use the 1Password Troubleshooting tool to generate a Diagnostics Report as soon as possible:

    https://support.1password.com/diagnostics/mac.html

    Then attach the report file with an email to: [email protected]

    Please do not post your Diagnostics Report in the forums, and do include a link to this discussion and your forum username in the email. You'll receive an automated email reply with a support ticket confirmation ID that you can post here to help "connect the dots".

    As receiving the report we'll continue to assist you with this issue directly through email. Thanks in advance!

This discussion has been closed.