Lollipop on nexus 5 unable to update to 4.2b2

Hi guys

This is a weird one - when I lauch 1password 4.2b1 on my nexus 5 I get prompted to install the upgrade. I attempt to do so by clicking the Update button and my phone tells me that installation from unknown sources is not enabled.

BUT... It is enabled in settings and I still get told by the updates that it isn't! (I enabled it after the first time I tried the update)

Is there a download link for the .apk file so I can try a manual update?


  • P.s. I've tried rebooting the phone and then trying again, and get the same problem.

  • P.p.s. I just tried re downloading the Adblock plus .apk from their website and installing that and it installed fine, so installing from unknown sources is definitely working OK.

    Looks like it's something with the 1password update notification?

  • Same problem on Nexus 4

  • Good to see I'm not alone - also experiencing the same problem on my Nexus 5.

  • "Me three."

    Same problem with Nexus 5 and Lollipop.

  • I had the same issue. I managed to update by clicking on the download link in the last beta email that was sent out on Nov 12th from Nik Lal.

  • For me it's the same problem. (Nexus 5 Lollipop)

  • Thanks, laestrella, I managed to update using your tip.

  • edited November 2014

    Thanks laestrella, had to find the last newsletter email in my gmail recycle bin and have downloaded and installed that way!

    (I've bookmarked the link from the email for future reference, and so far b2 seems to have made auto fill in chrome start working again without 1password crashing)

  • mverdemverde

    Team Member

    Hi everyone,

    As @laestrella‌ suggested, updating from the link provided in the beta newsletter should always work (provided that you have Unknown sources enabled). I believe this may be related to a known issue between the L preview version of Lollipop and the HockeyApp SDK that can interfere with updating the app. HockeyApp has indicated that this shouldn't be an issue with the release version of Lollipop. Could those of you experiencing this issue please let me know which Android version (Settings > About phone > Android version) and which Build number (same location, a little further down the screen) you are using? Thanks!

  • Android Version: 5.0 build number: LRX210. I managed to update 1password to use the link in the newsletter.

  • ditto Clarencexue -- 5.0 build LRX21O, also able to update via email link but not via app itself.

  • mverdemverde

    Team Member

    Thanks for the information @Clarencexue‌ and @tvandinter‌! It looks like you are both running the production version (factory image) of Lollipop. After some more testing, I have confirmed that I can reproduce the issue on my devices running Lollipop as well. I will pass this on to our development team and have them follow up with HockeyApp. In the meantime, I'm glad to hear that the newsletter link is a workable solution.

  • Not related to this, but when trying to update to 4.2b2 i get:

  • same issue here on Moto X Pure on Lollipop

  • saadsaad

    Team Member
    edited November 2014

    Thank you everyone for reporting this problem. While our team continues to investigate into this issue further, we have added this as a known issue along with the workaround that was brought up here.

  • thanks for the tip. :)

  • mverdemverde

    Team Member

    Happy to help! We've managed to confirm with HockeyApp that they have a fix for this in a beta version of their SDK. We are in the process of evaluating the updating SDK. Assuming that goes well and we integrate the updated SDK, then that update would be the last one that you would need to manually install from the newsletter link.

  • So, today I received a notification to update to b3, but as I am on Lollipop I'm running into the issue where I can't install from unknown sources even though I have that option turned on.

    The sticky thread says to work-around using the link from the email newsletter, but I didn't receive an email newsletter announcing b3. Where can I find the manual link to update to b3?

  • mverdemverde

    Team Member

    @ENDelt260‌ I merged your question in with the existing thread on the beta update issue, as the answer will probably benefit a number of our beta testers.

    The URL of the download link that is sent out in each beta newsletter doesn't change from one beta version to the next. This means that you can bookmark the URL and continue using it to update to the latest beta long after you have deleted the newsletter (don't tell Nik that you're deleting the newsletter though). I hope that helps!

  • same problem. moto x 2014 lollipop. this really is a problem because 1password quits every time it is launched, so i'm pretty much dead in the water. would love to know a fix for this asap!

  • pntuckerpntucker Junior Member

    this has popped up again with b5 on a nexus 4 & lollipop.

  • periperi

    Team Member

    @chnacat‌ and @pntucker‌ Have you tried updating via the download link in the beta newsletter?

This discussion has been closed.