1PW mini focus issues when invoking via Chrome extension

I've seen a few threads about focus issues when unlocking 1PW with the master password, but that seems to work relatively well for me. It's when 1PW is already unlocked and I open 1PW mini using the Chrome extension that mini doesn't focus and I have to click on it to get it to focus properly. I can't use the arrow keys to select entries or search without first clicking on mini. Chrome appears to maintain focus, as it remains "highlighted" as the active window in the taskbar even when mini shows up (until, of course, I click on mini). If I use Ctrl + Alt + \ or click on the icon in the system tray mini focuses just fine.

Interestingly, if I open the main 1PW window, immediately close it, then invoke mini via the Chrome extension, window focus works properly... for a few minutes. But inevitably the focusing issues come back. I haven't narrowed down what exactly causes the issue to reappear, but it seems to happen when browsing certain sites.

Three sites that seem to trigger the issue are:

Whenever I browse any of those sites for more than a minute or two, the focusing issue reappears. Especially with https://web.parcelapp.net/. Simply visiting that site immediately causes the issue to come back. Though for some reason it seems to work fine in incognito mode (I have 1PW enabled in incognito). Maybe an extension I use is doesn't agree with 1PW? I'll continue to test it out.


1Password Version: 7.0.532
Extension Version: 4.7.0.90
OS Version: Windows 10
Sync Type: 1PW account

Comments

  • Tetryl91Tetryl91
    edited March 2018

    I actually just locked 1PW (when focusing worked fine), visited https://web.parcelapp.net/ and tried to unlock 1PW using the Chrome extension and I ran into focusing issues as well. So scratch that first part of my previous post, lol.

    [Edit] Just browsed https://resetera.com/ in incognito with 1PW as the only enabled extension and am still having the same thing happening, so I guess that browser extension theory is out the window as well.

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @Tetryl91,

    Thanks for reporting this!

    I was really hoping you've found the way to reproduce this because it would've been easy to find a fix for it but unfortunately, I cannot reproduce the issue on any of the sites. We've seen scattered reports for a few years but we have not found a single case that's reproducible on any machines. We even had a few remote sessions and it wasn't showing up in there.

    If you reboot into safe mode with networking, can you reproduce it? Here's how for Windows 10: https://support.microsoft.com/en-us/help/12376/windows-10-start-your-pc-in-safe-mode

    When you said you tried to unlock 1Password using Chrome, is that with the shortcut (Control + \) or clicking on 1Password icon in the browser's toolbar?

  • @MikeT It's only when clicking on the icon in the browser toolbar. Ctrl + \, Ctrl + Alt + \, and clicking the 1PW icon in Windows' notification area all work fine with no focusing problems. And I just recently noticed that I only run into the issue if I'm using the touchpad on my laptop. If I only use a USB mouse I never get any focusing issues, or at least not often enough to notice. I even tried it on another laptop that was a different brand and got the same result. Touchpad = issues within a few minutes. Mouse = browsed for a half hour or more with no issues.

    Thing is, I can't figure out what I'm doing with the touchpad, if anything, that causes the problem to trigger. And when the issue does happen, if I switch to a mouse afterward, I still get focusing problems even with the mouse (until I open the main 1PW window to "reset" the focusing). But if I use only the mouse from then on it's smooth sailing.

    I'll try the safe mode thing right now and report back.

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @Tetryl91,

    What kind of trackpad is it? Does it have its own custom software to manage it? Can you disable the custom software to see if it works better without it?

  • Tetryl91Tetryl91
    edited March 2018

    @MikeT Just browsed around with the trackpad in safe mode for around 20 minutes and had no problems. It's listed as "Lenovo Pointing Device", but seems to be a Synaptics underneath. I can try disabling the "Synaptics Touchpad 64-bit Enhancements" entry in my Windows startup, but other than that the Lenovo Pointing Device software seems to be part of the driver. [Edit] Don't have access to the other laptop right now (it's a Dell) but when I do I'll check that trackpad too.

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @Tetryl91,

    Please do try to disable it or narrow it to a specific setting.

  • Tetryl91Tetryl91
    edited March 2018

    @MikeT Found it. Two finger scrolling being enabled breaks it. There are options for vertical and/or horizontal scrolling, and it doesn't matter if only one of them or both are on, it causes focusing problems. If trackpad scrolling is off, everything works perfectly.

  • Tetryl91Tetryl91
    edited March 2018

    @MikeT Double posting to make sure you don't miss this. Tested this on the other laptop. Don't know what brand the trackpad actually is (laptop is Dell), but it's one of those "precision touchpads" that seems to be using a Microsoft provided driver. All I see in device manager is two "HID-compliant mouse" entries, one of which is the USB mouse I have, and a "PS/2 compatible mouse". All using MS drivers.

    Anyway, all the settings for it are in the Windows settings app, and just like with the trackpad on the Lenovo laptop, when two finger scrolling is enabled I have focusing problems. Everything seems to work fine when I turn that off. In addition, with scrolling off, I kept accidentally triggering pinch to zoom and that broke 1PW focusing too. So I turned that off as well. I'm going to test pinch to zoom on the Lenovo and see what happens. [Edit] Pinch to zoom also breaks 1PW focusing on the Lenovo.

  • brentybrenty

    Team Member
    edited March 2018

    Found it. Two finger scrolling being enabled breaks it. There are options for vertical and/or horizontal scrolling, and it doesn't matter if only one of them or both are on, it causes focusing problems. If trackpad scrolling is off, everything works perfectly.

    @Tetryl91: Whoa. Thank you! As I was following along with this discussion just now, that's the direction I was thinking in too, and I was about to ask. But it looks like you were able to narrow it down already. Awesome! :love:

    Double posting to make sure you don't miss this. Tested this on the other laptop. Don't know what brand the trackpad actually is (laptop is Dell), but it's one of those "precision touchpads" that seems to be using a Microsoft provided driver. All I see in device manager is two "HID-compliant mouse" entries, one of which is the USB mouse I have, and a "PS/2 compatible mouse". All using MS drivers.

    No problem! Thanks again! I've shared this with Mike and the rest of the team. It's long been our white whale, so even though there may be other causes for focus issues out there as well, this may help a lot of people. :chuffed:

    Anyway, all the settings for it are in the Windows settings app, and just like with the trackpad on the Lenovo laptop, when two finger scrolling is enabled I have focusing problems. Everything seems to work fine when I turn that off. In addition, with scrolling off, I kept accidentally triggering pinch to zoom and that broke 1PW focusing too. So I turned that off as well. I'm going to test pinch to zoom on the Lenovo and see what happens. [Edit] Pinch to zoom also breaks 1PW focusing on the Lenovo.

    Very helpful! One thing that I really miss on Windows is that whatever Apple does with their trackpad hardware and software to avoid incorrect or accidental input is really amazing. I think I may not have seen issues like this myself because I turn a lot of this stuff off in Windows to make it more reliable in that regard. Thank you so much for sharing your findings here with the community! :)

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @Tetryl91,

    That's great, I'll let our developers know. Unfortunately, I am not able to reproduce this at all with my Surface Pro 4, nor did we hear from other Surface users that has the same precision touchpads with all of these settings enabled by default as far as I know.

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @Tetryl91,

    Sadly, our developers do not believe this is the cause. The problem is that this specific cause would've affect a massive number of our users and so far, this is only affecting less than 1%.

    Can you try to reproduce it in Firefox to rule Chrome out?

  • Happens in Firefox too. Exact same thing. Only happens when using the extension icon on the toolbar (oh, and right clicking in the browser and selecting 1Password from the context menu). Bringing up mini with the keyboard shortcut or the icon in the notification area works fine every time.

    I still think it's related to the touchpad somehow. In fact, in Firefox it breaks more consistently.

    In Firefox:
    1. If mini's focus is already broken, open the main 1PW window to fix focus.
    2. Go to Firefox and scroll with the touchpad (seems any website will do).
    3. Open 1PW mini with the extension icon on the toolbar. Focus is fine. Close 1PW mini.
    4. Scroll again. Reopen 1PW mini with the extension icon. Focus is broken.

    I just did it like 15 times in a row. And if I use my USB mouse, everything is fine. But the moment I use the touchpad to scroll or pinch to zoom, it breaks.

    Here's a video to show what I mean: https://photos.app.goo.gl/bCNiH57Uav5bQxkz2

    Before the video I opened the main 1PW window to fix the focus, but I didn't show it for obvious reasons.

    • At 0:00, I scroll with the trackpad and open mini and focus works fine (you can see when I click on mini Firefox isn't highlighted as the active window down in the taskbar anymore).
    • I close mini, scroll with the trackpad again and at 0:08 I click on mini again. It comes up, but Firefox is still highlighted as the active window in the taskbar, and I can't type anything in the search bar or use the keyboard to navigate, or even dismiss 1PW mini until I click on it. You can see me trying to dismiss it at 0:16.
    • Clicking on mini makes it the active window, after which I can use it normally. But when I dismiss mini and bring it up again, the focus is broken and I have to click on it every time to focus properly. Then I open the main 1PW window to "reset" it, and rinse and repeat.

    I expect you won't be able to reproduce this, as I'm sure it's something specific to my setup. I just don't know what it could be. It happens on two different laptops from different manufacturers with different touchpad drivers. The only thing I can think of is there's some software I'm running on both computers that is conflicting with 1PW somehow. I just don't know what that program could be. I'm not using anything that would obviously affect how scrolling works. It's weird.

  • brentybrenty

    Team Member

    @Tetryl91: Thanks for the additional information. That's really interesting, and I think you may be onto something with the trackpad. I can't think of cases where a regular mouse was involved. I have a potentially stupid question: since I noticed that you have Firefox pinned in the task bar, do you see any difference with this focus issue if you also pin 1Password in the task bar? I always have 1Password there, and I suspect many others do too, so I wonder if Windows is being a bit weird with the focusing at least partly because there's no "active" app in the traditional sense. The OS has come a long way, but there's still some legacy baggage (the devs are screaming as I write this, I can hear it, "SOME?!?!?!")

  • @brenty Nah, it's the same with 1PW pinned. Tried it with the main 1PW window both closed and minimized. No change.

  • brentybrenty

    Team Member
    edited March 2018

    @Tetryl91: I wasn't too hopeful, but thanks for trying. :(

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file