Wifi Sync Issue with OS X Yosemite: Mac not available in device list

edited October 2014 in iOS

I am not able to sync my iPhone with my MacBook anymore since I have updated to OS X Yosemite (official release from AppStore; with Mavericks it was working just fine).

My setup is an iPhone 5s with iOS 8.0.2 and 1Password 5.1 as well as a MacBook Pro MY 2011 with OS X Yosemite and 1Password 5.0 (downloaded from the AppStore).
If I am trying to start the Wifi sync on my iPhone the MacBook does not show up in the device list of 1Password even though the 1Password app on the MacBook is open and the settings screen with activated option "wifi sync..." is on top.

What I have already tried to fix the issue:

  • Different sequences and timings of activating the OS X and iOS app
  • Switched off MacBook and iPhone
  • Added 1Password apps to the list of apps that are allowed to accept incoming connections within the OS X firewall
  • Switched off the OS X firewall on the MacBook (I am not using any 3rd party firewall or Antivirus software)
  • Deleted and reinstalled Apps on MacBook (from AppStore) and iPhone
  • Used ad-hoc Wifi network and a different router

On the Internet you can find some reports that the bonjour service has been changed in the late Yosemite Betas as well as in the final versions. Maybe it is related to that.

Has anyone the wifi sync with Yosemite final and iOS 8.0.2 working?

Comments

  • Since I upgraded my iPhone to iOS 8, and 1Password 5.0, I can no longer sync my data over WiFi.

    The list of devices in the WLAN-Sync remains empty.

  • MeganMegan 1Password Alumni

    Hi @MKallweitt‌

    I'm so sorry to hear that you're having trouble keeping things synced up using Wi-Fi. Please ensure that all your devices are using the same Wi-Fi network and that you don't have any firewalls that could potentially be blocking communication between the desktop and iOS apps.

  • dsbdsb Junior Member

    Same issue here. Worked fine until after upgrade MacBook Pro to OS X 10.10 Yosemite, w/ 1PW 5.0.1; iPad Mini iOS 8.0.2 /w 1PW 5.1
    Set up in 1PW on MBP... Window>Wi-Fi Sync. Then 'Settings>Sync>Start Syncing>Sync using Wi-Fi'. Result: A brief flash of a message "One moment please"... in the 'Wi-Fi Sync' screen followed by a 'how to do' message. No other 'action' options except "Refresh List", which when pressed yielded no result. That's all she wrote. I'm sure it'll get sorted - just chiming in.

  • Hi from France,

    I have some Wi-Fi Sync troubles too here, using 1Password between my Iphone 6 plus iOS 8.0.2 and my Macbook Pro 2009 with Yosemite (10.10).

    I only do the sync with Wi-Fi option (local). Unfortunately, Wi-Fi option doesnot work for me now. I have this error report : « Error Domain=NSPOSIXErrorDomain Code=60 « The operation couldn’t be completed. Operation time out » after few seconds synch lauch. It might be come from Yosemite, iOS 8, new version of 1Password with new Wi-Fi local or even HideMyAss (VPN on Mac uninstalled now).

    I really thank you for your time.

  • @mayhem‌ I had the same problem as you initially and found a solution that worked for me: see this post. However, others have said it doesn't work for them so I'm not sure whether it will help you.

    Bonne chance!

    Stephen

  • It works for me. Merci beaucoup ;)

  • edited October 2014

    The "error domain" issue seems mostly firewall related.

    However this is NOT my issue. Please keep this thread limited to the issue "MacBook doesn't show up in iOS device list for wi-fi syncing with Yosemite final on the MacBook and iOS 8.0.2 on the iPhone 5s".

    Any help is welcome.

  • There is also a relevant thread just started on the 1P for OS X forum, which relates directly to one device not seeing another when attempting wifi sync.

    Stephen

  • wakko1999wakko1999
    edited October 2014

    I just updated my iPhone to 8.0.2 last night and my sync was working fine with os x 10.8.4. I just updated my computer to Yosemite today and updated my 1password to 5.0 (AppStore) and I ran into the same thing as you with the computer not showing. What I found was that if I open my phone to the wifi sync window, closed 1p5 on my computer and then re-opened 1p5 that my computer would appear for 1 second and then disappear. After three times, I tried it again and tried to quickly tap on the computer name to get to the next screen on the phone to start sync and I was successful and was able to do one sync. Hoping it would stay, I closed everything and started again as if I were doing a new sync and my computer flashed and disappeared again and refresh didn't bring it back.

    to eliminate the firewall as the issue I completely turned off my firewall and tried again. Same result. It eventually stayed after I did the below steps (not sure what corrected it, but this is just the sequence I followed and now my computer appears in my iPhone wifi sync window consistently).

    1. turned off OS X firewall
      2, opened the 1pwd wifi sync window on iPhone
    2. opened 1p5 on computer (computer flashed 1 sec on iPhone and disappeared) opened wifi sync on computer
    3. on the computer I toggled the wifi sync setting off and then on again (computer then appeared on my iPhone)
    4. tapped on my computer in 1pwd on my iPhone and did a sync
    5. closed both iPhone and computer 1p5 and turned firewall back on to test
    6. opened 1pwd on iPhone and opened wifi sync window
    7. opened 1p5 on computer (pc appeared on iPhone wifi sync window)

    I opened and closed both a few times and it now appears to be working correctly, for now...

    hope this helps someone...

  • wakko1999wakko1999
    edited October 2014

    Spoke too soon....right after posting that I went back to see if it was still working and it was not showing my computer on my iPhone. again. only way to get it to show up is to toggled the wifi sync on/off and it appears just long enough to tap it to get to the next window to start sync...

    notice now that after doing the sync my computer will stay in the window consistently until 1pwd on the iPhone auto locks or the iPhone goes to sleep. Once I have to unlock 1pwd again on my phone then the computer will no longer appear until wifi sync is toggled on and off again....so....

    1. open 1pwd on phone, go to wifi sync window
    2. toggle wifi sync on computer (computer will appear on iPhone)
    3. quickly tap computer on iPhone and do a sync
    4. computer will continue to appear on iPhone until the phone goes to sleep or 1pwd auto locks....after that computer does not appear and refresh doesn't work

    back to step 1

    All of the above was done with the firewall off. Interestingly, with the firewall on, I can still go through steps 1-3 above and get a sync, but the pc will be gone immediately upon exiting the sync screen whereas with it off the pc continues to display....

  • A full restart is the only reliable method so far.

  • Just updated my iPhone to iOS 8.1 but still no joy.

    Whatever I try the MacBook Pro is not showing up in the list of devices within the iOS app.

  • The only consistency I can find is it quits working at some point switching from wired to WIFI and back.

  • Not able to sync my iPhone and iPad (both IOS8.1) with my MacBook (OSX 10.10) via Wi-Fi. My MacBook name does not popup, list remains empty.

  • There have been other threads about problems with wifi sync. Does the suggestion in this AgileBits post help at all?

    Stephen

    Stephen

  • MeganMegan 1Password Alumni

    Hi everyone,

    Some of you have written some pretty detailed troubleshooting steps that you've tried already, but I'll just include the full list below for those of you who may not have tried this already:

    • Ensure that all your devices are using the same Wi-Fi network
    • Ensure that you do not have any firewalls enabled, or if you do that 1Password or localhost ( 127.0.0.1 ) is allowed to communicate
    • Make sure that the 'secret' window is open on your Mac

    If all those check out, try restarting 1Password and the Mini, like so:

    • Open 1Password.
    • Click the 1Password menu, hold down the Control key, and select Quit 1Password and 1Password mini.
    • Restart the Mac.
    • Relaunch 1Password.

    The next step is to create an ad-hoc network. We've got instructions on how to set that up here

    If you're still having trouble after going through these steps (as I think @OnePassword and @wakko1999‌ may be ), please send in a Diagnostics Report so we can take a closer look at where things are getting tangled up:

    https://guides.agilebits.com/kb/1password4/en/topic/diagnostics-report#mac4

    Then attach the entire file to an email to us: [email protected]

    Please do not post your Diagnostics Report in the forums, but please do include a link to this thread in your email, along with your forum handle so that we can "connect the dots" when we see your Diagnostics Report in our inbox.

    A short note here once you've sent the Report in will help us to keep an eye out for it. :)

    Once we see the report we should be able to better assist you. Thanks in advance!


    Finally, I just wanted to quote something one of our developers mentioned in the thread that @Stephen_C linked to above:

    WiFi sync is an area that we're still putting a lot of focus on, and we've experienced some of those same problems ourselves. We absolutely want to make it better.

    We appreciate your help in tracking this issue down so we can improve Wi-Fi sync for you all!

  • @Megan: I just sent a diagnostic report.
    Even though I tried all your suggestions multiple times and also reinstalled everything multiple times the MacBook does not show up in the device list of my iPhone.

    Thank you in advance for your support.

  • Ok, I just solved my issue by changing the computer name of my MacBook.

    I came across this accidentially by reading this thread in the beta area: https://discussions.agilebits.com/discussion/29351/wifi-sync-not-working#latest

    The computer name of my MacBook Pro was something like "first-name last-name MacBook Pro".
    I changed this under system preferences --> sharing --> computer name (in German it is Systemeinstellungen --> Freigaben --> Gerätename) to "first-nameMBP" (short and no spaces). After a reboot of the macbook and starting 1Password on the Mac the MacBook is shown in the device list of the iPhone ;-)

    Really weird but it seems that either the length of the computer name or the spaces between the words is causing an issue with Bonjour.

    Hope this helps others too.

  • WDCWDC
    edited October 2014

    Yosemite and iOS 8.1 and not syncing. It simply says syncing when I tell it to sync from the phone, but nothing happens. I tried to submit a report from the phone, but it crashes when I tell it to email settings. It has not synced since installing Yosemite. I thought iOS 8.1 would solve the problem, but it does not.

  • alanbralanbr
    edited October 2014

    Me too: "Ok, I just solved my issue by changing the computer name of my MacBook." THIS IS THE CULPRIT. I have tested and apparently the problem is not with spaces in the computer name, but rather the length of the name. Up to 28 characters is ok, but more than that will result in no WiFi sync.

  • dsbdsb Junior Member

    Bingo! Wi-Fi Sync successful. :) The sad thing is... not sure exactly what I did to get the good result, except for:
    [A] deleting (1) and disabling (1) Safari extensions; and
    [B] changing my computer name back to what it used to be running OS X 10.9.5 Mavericks. I noticed the name in Yosemite was appended with (2) after the old name. So I changed it back.
    Best of luck to all who are struggling with this frustrating issue.
    Cheers, dsb

  • The Computer name length was the issue. I've been trying things for 3 days! Move this hint to the top of the list.

  • Thanks @Megan for the response. I was coming back to the forum to post that I appeared to have resolved my issue and saw your post and a few others. Unlike others that have changed their computer names and got success, I ended up clearing and re-entering the secret password on my phone and now my computer is appearing consistently even after exiting 1pwd and through phone reboots. Possibly something with a trust got out of whack after upgrading somehow (??)

  • wakko1999wakko1999
    edited October 2014

    darn!! It's back. I think my problem is different than what everyone else is experiencing and I may start a separate post since this issue seems to be resolved. My issue is that the computer does not appear, but if I toggle Wifi Sync on/off on the computer it appears momentarily then disappears. If I tap on it while it is showing I can start a sync. After sync the computer sometimes stays other times it disappears again....I did the computer rename and that did not correct the issue for me....

    I'll send a diagnostic report tomorrow as I have to head out right now....

  • MeganMegan 1Password Alumni

    Hi guys,

    Thanks so much to @OnePassword for testing things out! I've passed this information along to our developers, and it turns out there's definitely something wonky going on with the computer names. They're already looking into it, and we'll do what we can to improve 1Password's behaviour here soon.

    @‌wakko1999,

    If you are seeing something different than the other posters here, a Diagnostics Report will be very helpful in tracking down just where things are getting tangled up! We'll take a look at it whenever you're ready to send it in. :)

  • Checked my iPad and it synced fine, so I deleted 1PW for iPhone, downloaded it from my iTunes Cloud, and it sync'd right up. Did this after installing 5.0.2 b3 on my Mac. (I don't use WiFi Sync. I sync with DropBox.) All appears to be fine now.

  • BenBen AWS Team

    Team Member

    Thanks for the update @WDC!

  • Oops, I just posted a similar problem with newer versions in another discussion...

  • BenBen AWS Team

    Team Member
This discussion has been closed.